Bug 733975 - abrtd daemon need "messagebus" daemon, please update "Required-Start" section of /etc/init.d/abrtd
Summary: abrtd daemon need "messagebus" daemon, please update "Required-Start" section...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Nikola Pajkovsky
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-29 02:21 UTC by Gris Ge
Modified: 2014-02-02 22:15 UTC (History)
9 users (show)

Fixed In Version: abrt-2.0.4-10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 12:21:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1598 normal SHIPPED_LIVE abrt and libreport bug fix and enhancement update 2011-12-06 00:51:16 UTC

Description Gris Ge 2011-08-29 02:21:59 UTC
Description of problem:

abrtd need dbus which is provided by messagebus daemon. User might disable messagebus which cause abrtd cannot start:
===
abrtd: Failed to start: timeout waiting for child
===
abrtd -vvvv show the correct reason:
===
abrtd: dbus error: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
abrtd: Error requesting DBus name com.redhat.abrt, possible reasons: abrt run by non-root; dbus config is incorrect; or dbus daemon needs to be restarted to reload dbus config
abrtd: Failed to start: timeout waiting for child
===

You might also think about change the warning message of /etc/init.d/abrtd, it don't provide any useful information with "timeout waiting for child".

Version-Release number of selected component (if applicable):
RHEL 6.1

How reproducible:
100%

Steps to Reproduce:
1. Stop messagebus daemon
2. Start abrtd daemon
  
Actual results:
abrtd start failed with meaningless error message.

Expected results:
Abrtd require messagebus in LBS header and provide useful error message to user.

Additional info:

Comment 1 Nikola Pajkovsky 2011-08-30 12:38:43 UTC
(In reply to comment #0)
> Description of problem:
> 
> abrtd need dbus which is provided by messagebus daemon. User might disable
> messagebus which cause abrtd cannot start:
> ===
> abrtd: Failed to start: timeout waiting for child

this is printed out, but take a look at /var/log/message. The rest of error message is there. If you invoke abrtd without -d and -v it will put all logs into /var/log/message

> You might also think about change the warning message of /etc/init.d/abrtd, it
> don't provide any useful information with "timeout waiting for child".

that message comes from abrtd binary not from init script

Comment 2 Gris Ge 2011-09-01 08:27:30 UTC
Thanks for the info.

Then we only update the LSB header as the subject of this bug.

Comment 3 Nikola Pajkovsky 2011-09-07 15:02:56 UTC
I'm going to close the bug as NOTABUG. The reasonable message is printed out to /var/log/messages when -d and -v options are not specified.

Feel free to reopen for rhel6.3 if you think that message needs to be printed out for stderr without options -d and -v.

Comment 4 Nikola Pajkovsky 2011-09-07 15:49:51 UTC
commit f1ddb9c8cb8fb1ce536757770245a09bc5c731ab
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Wed Sep 7 17:32:09 2011 +0200

    update LSB header
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
    (cherry picked from commit f853345031ae3e8cf39d1608aa0a2adb14a1ef8c)

Comment 8 errata-xmlrpc 2011-12-06 12:21:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1598.html


Note You need to log in before you can comment on or make changes to this bug.