Bug 733982 - Still gnome3 desktop uncomplete after boot and first login
Summary: Still gnome3 desktop uncomplete after boot and first login
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 04:16 UTC by Joachim Backes
Modified: 2013-02-13 19:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 19:48:27 UTC


Attachments (Terms of Use)
~/.xsession-errors (8.64 KB, application/octet-stream)
2011-08-29 05:26 UTC, Joachim Backes
no flags Details
~/.xsession-errors.old (18.86 KB, application/octet-stream)
2011-08-29 05:27 UTC, Joachim Backes
no flags Details
/var/log/gdm/:0-greeter.log (23.10 KB, text/x-log)
2011-08-29 06:02 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2011-08-29 04:16:06 UTC
Description of problem:
Still after the most recent updates on my box:
[
Aug 29 05:52:29 Updated: evolution-data-server-3.1.5-2.fc16.x86_64
Aug 29 05:52:30 Installed: p11-kit-0.4-1.fc16.x86_64
Aug 29 05:52:31 Updated: gnome-keyring-3.1.4-1.fc16.x86_64
Aug 29 05:52:32 Updated: gnome-menus-3.1.5-2.fc16.x86_64
Aug 29 05:52:33 Installed: libsocialweb-0.25.19-1.fc16.x86_64
Aug 29 05:52:34 Installed: libsocialweb-keys-0.25.19-1.fc16.noarch
Aug 29 05:52:35 Updated: 1:folks-0.6.0-5.fc16.x86_64
Aug 29 05:52:35 Updated: 1:control-center-filesystem-3.1.5-3.fc16.x86_64
Aug 29 05:52:42 Updated: 1:control-center-3.1.5-3.fc16.x86_64
Aug 29 05:52:42 Updated: gnome-contacts-0.1.2-2.fc16.x86_64
Aug 29 05:52:46 Updated: empathy-3.1.5.1-1.fc16.x86_64
Aug 29 05:52:48 Updated: gnome-shell-3.1.4-2.gite7b9933.fc16.x86_64
Aug 29 05:52:48 Updated: gnome-keyring-pam-3.1.4-1.fc16.x86_64
Aug 29 05:52:49 Updated: 1:nautilus-sendto-3.0.0-9.fc16.x86_64
]
having the following problem:

After booting, if the gdm login screen appears for the first time, the clock on the title 
bar is wrong. Then after logging in, the gnome3 desktop is incomplete 
(including missing title bar, no activities button,...). If in this 
state I logout (for example by Ctrl+Alt+Del) and then re-login, the 
desktop now is OK (clock OK, gnome3 title bar OK,...)


Version-Release number of selected component (if applicable):
gnome-shell-3.1.4-2.gite7b9933.fc16.x86_64

How reproducible:
See description

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Joachim Backes 2011-08-29 05:26:36 UTC
Created attachment 520284 [details]
~/.xsession-errors

Comment 2 Joachim Backes 2011-08-29 05:27:34 UTC
Created attachment 520285 [details]
~/.xsession-errors.old

Comment 3 Joachim Backes 2011-08-29 06:02:04 UTC
Created attachment 520288 [details]
/var/log/gdm/:0-greeter.log

Comment 4 Joachim Backes 2011-08-31 04:35:04 UTC
After the most recent updates (Aug 31), when  login after boot for the first timewith the GDM screen, I get an error message:

Failed to load session "gnome".

Pressing "logout" and re-login solves the problem.

Comment 5 Joachim Backes 2011-09-13 03:45:31 UTC
Even after having installed the giganto update 2011-12324, the very first login (after boot) into a gnome-shell session is incomplete: No gnome-shell titlebar, no favorites bar, no menu if pressing alt+f2. This can be repaired by logging out and login again (by pressing ctrl+alt+del and then pressing the logout button in the presented menu). Now the gnome-shell behaviour is flawless at each new login, until to the next reboot.

Comment 6 Alexander Todorov 2011-10-06 09:11:13 UTC
I have the same issue with F16 Beta. See screenshot at:
https://bugzilla.redhat.com/attachment.cgi?id=526651

1) I did a default install in a KVM guest
2) Selected all defaults in anaconda and completed the install
3) Went through firstboot to add a new user and tried to login

Actual results:
A big error message telling me GNOME 3 failed to load

Expected results: 
No errors.

Comment 7 Cristian Gheorghe Florescu 2012-04-01 16:31:14 UTC
Hello all,

Somebody could give any workaround on this or maybe another status to bug?

This bug occur on my INTEL GM965 and also to ATI Radeon 540 GMA

http://forums.fedoraforum.org/showthread.php?t=277446

I've tried also with normal kernel (non PAE) 32 bits

Any help is appreciated.

Comment 8 Fedora End Of Life 2013-01-16 16:17:59 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Fedora End Of Life 2013-02-13 19:48:31 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.