Bug 733989 - Sync should give meaningful error (not segfault) when pilot-link is not installed
Summary: Sync should give meaningful error (not segfault) when pilot-link is not insta...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pilot-link
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Schiffer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 709098 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 05:03 UTC by Matt McCutchen
Modified: 2012-07-26 10:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-12 00:28:41 UTC


Attachments (Terms of Use)

Description Matt McCutchen 2011-08-29 05:03:41 UTC
Description of problem:
Due to bug 733987, I got into a state with pilot-link-libs but not pilot-link installed and then tried to sync.  Without the udev rules from pilot-link, the library was unable to open the USB device and segfaulted because it did not null check the return from usb_open.  This took me some time to trace down.

Given that the current packaging structure anticipates the possibility of pilot-link-libs being installed without pilot-link, the library should give a meaningful error message in this situation.  Alternatively, the packaging could be restructured.

Version-Release number of selected component (if applicable):
pilot-link-0.12.5-5.fc15

How reproducible:
Always

Steps to Reproduce:
1. Have pilot-link-libs installed and pilot-link uninstalled.
2. Attempt to sync, e.g., with gnome-pilot.

Actual results:
Segfault.

Expected results:
Error message, e.g., "Failed to open USB device.  Make sure you have the udev rules installed (in pilot-link in Fedora)."

Comment 1 Peter Schiffer 2012-06-01 17:15:42 UTC
fixed in rawhide:
pilot-link-0.12.5-11.fc18
http://koji.fedoraproject.org/koji/buildinfo?buildID=321460

I've moved udev rules from the main package to the libs subpackage, so now the pilot-link-libs package is usable without pilot-link package.

Comment 2 Fedora Update System 2012-06-01 17:30:53 UTC
pilot-link-0.12.5-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pilot-link-0.12.5-11.fc17

Comment 3 Fedora Update System 2012-06-01 17:47:06 UTC
pilot-link-0.12.5-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pilot-link-0.12.5-9.fc16

Comment 4 Fedora Update System 2012-06-02 03:54:58 UTC
Package pilot-link-0.12.5-9.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pilot-link-0.12.5-9.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8761/pilot-link-0.12.5-9.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-06-12 00:28:41 UTC
pilot-link-0.12.5-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2012-06-12 00:34:11 UTC
pilot-link-0.12.5-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Peter Schiffer 2012-07-26 10:32:19 UTC
*** Bug 709098 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.