Bug 734015 - cannot mount 3TB sata drive from usb to sata docking station
Summary: cannot mount 3TB sata drive from usb to sata docking station
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Torez Smith
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 07:46 UTC by Natxo Asenjo
Modified: 2017-04-26 15:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-17 14:27:06 UTC


Attachments (Terms of Use)

Description Natxo Asenjo 2011-08-29 07:46:09 UTC
Description of problem:

When I plugin a 3TB sata drive on a usb to sata docking station the 3TB drive is not available to the system

Version-Release number of selected component (if applicable):
* rhel 6.1 fully patched (amd64), dell latitude e6500 laptop
* Bus 002 Device 010: ID 152d:2338 JMicron Technology Corp. / JMicron USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge
* WD 3TB sata drive WDC WD30 EZRX-00MMMB0

How reproducible:
always

Steps to Reproduce:
1. plug sata 3TB drive to usb to sata docking station
2. turn power on of the docking station
3. connect docking to laptop with usb cable
  
Actual results:

Aug 29 09:05:10 host kernel: usb 1-3.2: new high speed USB device using ehci_hcd and address 8
Aug 29 09:05:10 host kernel: usb 1-3.2: New USB device found, idVendor=152d, idProduct=2338
Aug 29 09:05:10 host kernel: usb 1-3.2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
Aug 29 09:05:10 host kernel: usb 1-3.2: Product: USB to ATA/ATAPI bridge
Aug 29 09:05:10 host kernel: usb 1-3.2: Manufacturer: JMicron
Aug 29 09:05:10 host kernel: usb 1-3.2: SerialNumber: 000001D91CA1
Aug 29 09:05:10 host kernel: usb 1-3.2: configuration #1 chosen from 1 choice
Aug 29 09:05:10 host kernel: scsi7 : SCSI emulation for USB Mass Storage devices
Aug 29 09:05:15 host kernel: scsi 7:0:0:0: Direct-Access     WDC WD30 EZRX-00MMMB0          PQ: 0 ANSI: 5
Aug 29 09:05:15 host kernel: sd 7:0:0:0: Attached scsi generic sg2 type 0
Aug 29 09:05:15 host kernel: sd 7:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
Aug 29 09:05:15 host kernel: sd 7:0:0:0: [sdb] 5860533168 512-byte logical blocks: (3.00 TB/2.72 TiB)
Aug 29 09:05:15 host kernel: sd 7:0:0:0: [sdb] Write Protect is off
Aug 29 09:05:15 host kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 09:05:15 host kernel: sd 7:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
Aug 29 09:05:15 host kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 09:05:15 host kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:15 host kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:16 host kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:16 host kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:16 host kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:16 host kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:16 host kernel: sd 7:0:0:0: [sdb] Unhandled error code
Aug 29 09:05:16 host kernel: sd 7:0:0:0: [sdb] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
Aug 29 09:05:16 host kernel: sd 7:0:0:0: [sdb] CDB: Read(10): 28 00 00 00 00 00 00 00 08 00
Aug 29 09:05:16 lap0048-210307 kernel: end_request: I/O error, dev sdb, sector 0
Aug 29 09:05:16 lap0048-210307 kernel: Buffer I/O error on device sdb, logical block 0
Aug 29 09:05:16 lap0048-210307 kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:16 lap0048-210307 kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8
Aug 29 09:05:16 lap0048-210307 kernel: usb 1-3.2: reset high speed USB device using ehci_hcd and address 8


Expected results:
This is with another sata drive, 320GB
Aug 29 09:21:03 host kernel: usb 2-3: new high speed USB device using ehci_hcd and address 10
Aug 29 09:21:03 host kernel: usb 2-3: New USB device found, idVendor=152d, idProduct=2338
Aug 29 09:21:03 host kernel: usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=5
Aug 29 09:21:03 host kernel: usb 2-3: Product: USB to ATA/ATAPI bridge
Aug 29 09:21:03 host kernel: usb 2-3: Manufacturer: JMicron
Aug 29 09:21:03 host kernel: usb 2-3: SerialNumber: 000001D919A0
Aug 29 09:21:03 host kernel: usb 2-3: configuration #1 chosen from 1 choice
Aug 29 09:21:03 host kernel: scsi14 : SCSI emulation for USB Mass Storage devices
Aug 29 09:21:08 host kernel: scsi 14:0:0:0: Direct-Access     WDC WD32 00AAKS-75L9A0         PQ: 0 ANSI: 2 CCS
Aug 29 09:21:08 host kernel: sd 14:0:0:0: Attached scsi generic sg2 type 0
Aug 29 09:21:08 host kernel: sd 14:0:0:0: [sdb] 625142448 512-byte logical blocks: (320 GB/298 GiB)
Aug 29 09:21:08 host kernel: sd 14:0:0:0: [sdb] Write Protect is off
Aug 29 09:21:08 host kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 09:21:08 host kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 09:21:08 host kernel: sdb: sdb1
Aug 29 09:21:08 host kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 09:21:08 host kernel: sd 14:0:0:0: [sdb] Attached SCSI disk
Aug 29 09:21:09 host ntfs-3g[4447]: Version 2010.10.2 integrated FUSE 27
Aug 29 09:21:09 host ntfs-3g[4447]: Mounted /dev/sdb1 (Read-Write, label "System", NTFS 3.1)
Aug 29 09:21:09 host ntfs-3g[4447]: Cmdline options: rw,nosuid,nodev,uhelper=udisks,uid=500,gid=500,dmask=0077
Aug 29 09:21:09 host ntfs-3g[4447]: Mount options: rw,nosuid,nodev,uhelper=udisks,allow_other,nonempty,relatime,fsname=/dev/sdb1,blkdev,blksize=4096,default_permissions
Aug 29 09:21:09 host ntfs-3g[4447]: Global ownership and permissions enforced, configuration type 1

Additional info:

on the same laptop, dual boot with win7, it works and I can access the
3TB drive.

Comment 2 Ric Wheeler 2011-08-29 14:40:15 UTC
We don't support NTFS-3G in RHEL.

Do you see the same problem when using a supported file system like ext4?

Thanks!

Comment 3 Natxo Asenjo 2011-08-29 17:41:47 UTC
Yes, originally the disk was unformatted. I thought there was a problem with the partition table so I built it locally (no usb docking station, direct sata connection) in another pc with rhel 6.1 amd64 and it got detected.

I then used parted to make a gpt partition table and a ext4 file system. Everything worked on a direct sata connection.

Back to the usb-to-sata docking, nothing worked.

So, yes, in a direct sata connection with a ext4 filesystem it works. But this is a laptop, so I cannot install a 3''5 sata drive in it. That's why I want to use the docking station.

Comment 4 Ric Wheeler 2011-08-29 17:50:43 UTC
My experience has been that several of the USB/e-sata docking stations work for large drives only when you use the e-sata connection. I assumed without digging into that this was a failure on the USB firmware side, but it might be libata related.

When this works for you from windows, do you see the full size drive (3TB)?

What is the specific USB enclosure you used (I saw the bridge info above which is useful as well, thanks!)

Comment 5 Ric Wheeler 2011-08-29 17:55:58 UTC
I should have said USB SCSI related - libata is not used for USB devices I believe.

Comment 6 Natxo Asenjo 2011-08-29 18:15:00 UTC
Yes, windows sees the full drive size.

Comment 7 Natxo Asenjo 2011-08-29 18:18:09 UTC
Sorry, I missed your other question. I use no usb enclosure, this is a sharkoon drivelink usb 2 (if I may link the product, this is it: http://www.sharkoon.com/?q=en/content/drivelink-usb20). It works brilliantly with disks up to 2TB with rhel 6.1.

Comment 8 Natxo Asenjo 2011-08-31 17:44:23 UTC
update: I have bought a new usb docking station, a Sharkoon Quickport XT, and now I see the disk with usb. It only sees 801 GB, though:

Aug 31 19:36:42 host kernel: usb 2-3: new high speed USB device using ehci_hcd and address 6
Aug 31 19:36:42 host kernel: usb 2-3: New USB device found, idVendor=152d, idProduct=2336
Aug 31 19:36:42 host kernel: usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=5
Aug 31 19:36:42 host kernel: usb 2-3: Product: JM20336 SATA, USB Combo
Aug 31 19:36:42 host kernel: usb 2-3: Manufacturer: JMicron
Aug 31 19:36:42 host kernel: usb 2-3: SerialNumber: DCA104624288
Aug 31 19:36:42 host kernel: usb 2-3: configuration #1 chosen from 1 choice
Aug 31 19:36:42 host kernel: scsi9 : SCSI emulation for USB Mass Storage devices
Aug 31 19:36:47 host kernel: scsi 9:0:0:0: Direct-Access     WDC WD30 EZRX-00MMMB0          PQ: 0 ANSI: 2 CCS
Aug 31 19:36:47 host kernel: sd 9:0:0:0: Attached scsi generic sg2 type 0
Aug 31 19:36:47 host kernel: sd 9:0:0:0: [sdb] 1565565872 512-byte logical blocks: (801 GB/746 GiB)
Aug 31 19:36:47 host kernel: sd 9:0:0:0: [sdb] Write Protect is off
Aug 31 19:36:47 host kernel: sd 9:0:0:0: [sdb] Assuming drive cache: write through
Aug 31 19:36:47 host kernel: sd 9:0:0:0: [sdb] Assuming drive cache: write through
Aug 31 19:36:57 host kernel: sdb: sdb1
Aug 31 19:36:57 host kernel: sd 9:0:0:0: [sdb] Assuming drive cache: write through
Aug 31 19:36:57 host kernel: sd 9:0:0:0: [sdb] Attached SCSI disk
Aug 31 19:36:57 host kernel: EXT4-fs (sdb1): mounted filesystem with ordered data mode

lsub:
Bus 002 Device 006: ID 152d:2336 JMicron Technology Corp. / JMicron USA Technology Corp. Hard Disk Drive


Tomorrow I will get an e-sata cable and see if that way I can access the 3TB it has.

Comment 9 Don Zickus 2011-09-07 02:23:49 UTC
Hi Natxo,

I was looking through the list of special cases for broken usb devices and noticed JMicron has its own issues and quirks.  This just might be a new device that hasn't been updated into the quirk table.

On the kernel command line, can you add:

usb-storage.quirks=152d:2338:ra

I have never tried that but according to the kernel documentation that might work (it saves me from compiling a kernel and sending it to you).

Let me know if that helps or not.

Cheers,
Don

Comment 10 Natxo Asenjo 2011-09-07 16:59:07 UTC
Hi Don,

I have added that to the kernel line in /boot/grub/menu.lst and rebooted. Then I saw this:

Sep  7 18:46:33 host kernel: usb 2-1: new high speed USB device using 
ehci_hcd and address 4
Sep  7 18:46:33 host kernel: usb 2-1: New USB device found, idVendor=1
52d, idProduct=2338
Sep  7 18:46:33 host kernel: usb 2-1: New USB device strings: Mfr=1, P
roduct=2, SerialNumber=5
Sep  7 18:46:33 host kernel: usb 2-1: Product: USB to ATA/ATAPI bridge
Sep  7 18:46:33 host kernel: usb 2-1: Manufacturer: JMicron
Sep  7 18:46:33 host kernel: usb 2-1: SerialNumber: 000001D91CA1
Sep  7 18:46:33 host kernel: usb 2-1: configuration #1 chosen from 1 c
hoice
Sep  7 18:46:33 host kernel: usb-storage 2-1:1.0: Quirks match for vid 152d pid 2338: 8020
Sep  7 18:46:33 host kernel: scsi7 : SCSI emulation for USB Mass Storage devices
Sep  7 18:46:38 host kernel: scsi 7:0:0:0: Direct-Access     WDC WD30 EZRX-00MMMB0          PQ: 0 ANSI: 5
Sep  7 18:46:38 host kernel: sd 7:0:0:0: Attached scsi generic sg2 type 0
Sep  7 18:46:38 host kernel: sd 7:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
Sep  7 18:46:38 host kernel: sd 7:0:0:0: [sdb] 5860533168 512-byte logical blocks: (3.00 TB/2.72 TiB)
Sep  7 18:46:38 host kernel: sd 7:0:0:0: [sdb] Write Protect is off
Sep  7 18:46:38 host kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
Sep  7 18:46:38 host kernel: sd 7:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
Sep  7 18:46:38 host kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
Sep  7 18:46:39 host kernel: sdb:
Sep  7 18:46:39 host kernel: usb 2-1: reset high speed USB device using ehci_hcd and address 4
Sep  7 18:46:39 host kernel: usb 2-1: reset high speed USB device using ehci_hcd and address 4
Sep  7 18:46:39 host kernel: usb 2-1: reset high speed USB device using ehci_hcd and address 4

so the quirks change have made no difference, I am afraid.

E-sata is working fine, by the way.

I'll be gladly willing to donate the hardware to get it supported, by the way. This kind of cheap storage is really useful and it would be great to have it working in linux.

Comment 11 RHEL Product and Program Management 2011-10-07 15:46:16 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 12 Reartes Guillermo 2012-08-14 19:55:01 UTC
@Natxo Asenjo

There is some information (actually, a discussion about quirks) in the kernel mailing lists:

"JMicron 20337 (152d:2338) and 3TB" in:
http://comments.gmane.org/gmane.linux.usb.general/62798

Somebody pointed this to me, are you aware of it? (IMPORTANT)
http://bigacid.wordpress.com/2008/12/08/jm20337-read-data-corruption-solution/

Comment 14 Natxo Asenjo 2014-11-22 15:59:28 UTC
I just saw there is activity on this item. I no longer use the usb interface but always the e-sata one. So as far as I'm concerned the bug may be closed

Comment 15 antoszka 2017-04-23 20:36:21 UTC
Hello, 

please reopen this bug, the usb-storage driver still has the same problem, and the driver still reports ~800GB for a 3TB size whether with the usb quirks kernel option or not. Windows sees the drive properly.

# /proc/cmdline includes:
usb-storage.quirks=152d:2336:ra

# lsusb:
Bus 001 Device 016: ID 152d:2336 JMicron Technology Corp. / JMicron USA Technology Corp. Hard Disk Drive

# lshw:
              *-usb:0
                   description: Mass storage device
                   product: JM20336 SATA, USB Combo
                   vendor: JMicron
                   physical id: 1
                   bus info: usb@1:1
                   logical name: scsi3
                   version: 1.00
                   serial: DCC110616328
                   capabilities: usb-2.00 scsi emulated
                   configuration: driver=usb-storage maxpower=2mA speed=480Mbit/s
                 *-disk
                      description: SCSI Disk
                      product: EFRX-68AX9N0
                      vendor: WDC WD30
                      physical id: 0.0.0
                      bus info: scsi@3:0.0.0
                      logical name: /dev/sdb
                      size: 746GiB (801GB)
                      capabilities: gpt-1.00 partitioned partitioned:gpt
                      configuration: ansiversion=2 guid=e4915227-1c7f-4886-a21d-741941c2c893 logicalsectorsize=512 sectorsize=512


Note You need to log in before you can comment on or make changes to this bug.