Bug 734021 - host kernel panic while host running multiple TCP_RR.
Summary: host kernel panic while host running multiple TCP_RR.
Keywords:
Status: CLOSED DUPLICATE of bug 730756
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Herbert Xu
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 08:26 UTC by Quan Wenli
Modified: 2011-09-19 11:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 11:49:35 UTC


Attachments (Terms of Use)
backtrace of kernel panic (4.29 KB, application/octet-stream)
2011-08-29 08:26 UTC, Quan Wenli
no flags Details

Description Quan Wenli 2011-08-29 08:26:31 UTC
Created attachment 520313 [details]
backtrace of kernel panic

Description of problem:

host kernel panic while host running multiple TCP_RR.backtrace in attachment.

Version-Release number of selected component (if applicable):

kernel-2.6.32-191.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64

How reproducible:

always

Steps to Reproduce:
1.boot guest on the host.
/usr/libexec/qemu-kvm /home/kvm_autotest_root/images/RHEL-Server-6.2-64-virtio.qcow2 -netdev tap,id=hn0,vhost=on -device virtio-net-pci,netdev=hn0,mac=00:00:05:00:00:05 -m 4G -cpu cpu64-rhel6,+sse2,+x2apic -rtc base=utc,clock=host -usbdevice tablet -no-kvm-pit-reinjection -M rhel6.2.0 -enable-kvm -vnc :10
2.run netserver on the guest (ip is 192.168.100.3)
3.run multiple TCP_RR on the host (configure netperf with  --enable-burst)
  netperf -H 192.168.100.3 -t TCP_RR -- -b 25 -r 256,25

  
Actual results:

host kernel panic while host running multiple TCP_RR.

Expected results:


Additional info:

# sysctl -a |grep bridge
net.bridge.bridge-nf-call-arptables = 0
net.bridge.bridge-nf-call-iptables = 0
net.bridge.bridge-nf-call-ip6tables = 0
net.bridge.bridge-nf-filter-vlan-tagged = 0
net.bridge.bridge-nf-filter-pppoe-tagged = 0

# ethtool -k eth1
Offload parameters for eth1:
rx-checksumming: on
tx-checksumming: on
scatter-gather: on
tcp-segmentation-offload: on
udp-fragmentation-offload: off
generic-segmentation-offload: on
generic-receive-offload: on
large-receive-offload: off

# ethtool -i eth1
driver: ixgbe
version: 3.4.8-k
firmware-version: 0.9-3
bus-info: 0000:0f:00.1

# cat /proc/cmdline 
ro root=/dev/mapper/VolGroup-LogVol_root rd_LVM_LV=VolGroup/LogVol_root rd_LVM_LV=VolGroup/LogVol_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=129M@0M processor.max_cstate=1 nmi_watchdog=0 console=tty0 console=ttyS0,115200 rhgb quiet intel_iommu=off

Comment 4 Herbert Xu 2011-09-19 11:49:35 UTC

*** This bug has been marked as a duplicate of bug 730756 ***


Note You need to log in before you can comment on or make changes to this bug.