Bug 734022 - CLI Register works with invalid org arguments
Summary: CLI Register works with invalid org arguments
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: 738066 756082
TreeView+ depends on / blocked
 
Reported: 2011-08-29 08:30 UTC by Shwetha Kallesh
Modified: 2012-01-03 21:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-03 21:51:17 UTC


Attachments (Terms of Use)

Description Shwetha Kallesh 2011-08-29 08:30:15 UTC
Description of problem:
CLI Register works with invalid org arguments

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
subscription-manager register --user=admin --password=admin --org=admin owner

Or

 subscription-manager register --u admin --password admin --org donaldduck ownersssssss
  
Actual results:
The system has been registered with id: c76f1921-9258-4f35-9d6c-ffb94617f90f 


Expected results:

Registration should fail saying "Organization/Owner admin owner does not exist"

Additional info:

Comment 2 John Sefler 2011-08-29 13:24:29 UTC
To specify an org with a space in the name, bash requires that you quote the value.  Try this...

subscription-manager register --user=admin --password=admin --org="admin owner"

subscription-manager register --u admin --password admin --org "donaldduck
ownersssssss"

Comment 3 John Sefler 2011-08-29 13:48:16 UTC
see Bug 734114 - register with --org="foo bar" throws a NetworkException instead of a RestlibException

Comment 6 Bryan Kearney 2012-01-03 21:51:17 UTC
Closing this out since the quotes are required, and we have another bug with spaces already.


Note You need to log in before you can comment on or make changes to this bug.