Bug 734029 - hostapd not working with latest kernel (2.6.40.3-0.fc15.x86_64)
Summary: hostapd not working with latest kernel (2.6.40.3-0.fc15.x86_64)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 09:18 UTC by paul59584
Modified: 2011-08-29 11:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-29 11:42:52 UTC


Attachments (Terms of Use)

Description paul59584 2011-08-29 09:18:26 UTC
Description of problem:

client cannot connect to fedora 15 access point with latest kernel 2.6.40.3-0.fc15.x86_64. Has been working for years until this kernel installed 

Version-Release number of selected component (if applicable):

kernel-2.6.40.3-0.fc15.x86_64
hostapd-0.7.3-2.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot f15 machine used as access point with kernel 2.6.40.3-0.fc15.x86_64
2. try to connect to access point (with a macbook)
3. fails
  
Actual results:

with kernel-2.6.40.3-0.fc15.x86_64

Aug 29 20:56:27 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 IEEE 802.11: authenticated
Aug 29 20:56:27 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 IEEE 802.11: associated (aid 1)
Aug 29 20:56:27 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 IEEE 802.11: Could not add STA to kernel driver
Aug 29 20:56:30 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 IEEE 802.11: deauthenticated due to local deauth request


Expected results:

with kernel-2.6.40-4.fc15.x86_64 and previous kernels and fedora releases for a few years

Aug 29 21:00:28 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 IEEE 802.11: authenticated
Aug 29 21:00:28 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 IEEE 802.11: associated (aid 1)
Aug 29 21:00:28 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 RADIUS: starting accounting session 4E5B5515-00000000
Aug 29 21:00:28 panda hostapd: wlan0: STA 00:24:36:ae:b9:00 WPA: pairwise key handshake completed (RSN)


Additional info:

Comment 1 paul59584 2011-08-29 11:42:52 UTC
actually it's not working properly with older kernels or in f13 so this is not a kernel bug, maybe hardware problem? anyway i'm closing this bug report.


Note You need to log in before you can comment on or make changes to this bug.