Bug 734030 - Servlet from examples cannot send message into queue/topic
Summary: Servlet from examples cannot send message into queue/topic
Keywords:
Status: CLOSED DUPLICATE of bug 722614
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-jca
Version: 2.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: 2.0.4
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 09:22 UTC by Jiri Sedlacek
Modified: 2015-08-02 23:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-01 15:06:43 UTC


Attachments (Terms of Use)

Description Jiri Sedlacek 2011-08-29 09:22:23 UTC
Description of problem:

Servlet from examples cannot send message into queue/topic got from JNDI.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. unzip eap-5.1.1 package
2. configure examples to use this eap and correct profile
3. deploy queue/topic (by deploying AdminObject)
4. compile and deploy web example
5. run the example in web browser
  
Actual results:

11:15:09,665 INFO  [TomcatDeployment] deploy, ctxPath=/qpid-jcaex-web
11:15:23,617 INFO  [AMQConnection] Connection:amqp://guest:********@client_idtest?brokerlist='tcp://mrg01.mw.lab.eng.bos.redhat.com:5672'
11:15:23,617 INFO  [AMQProtocolSession] Using ProtocolVersion for Session:0-10
11:15:23,617 INFO  [ClientMethodDispatcherImpl] New Method Dispatcher:AMQProtocolSession[null]
11:15:23,617 INFO  [AMQConnection] Connecting with ProtocolHandler Version:0-10
11:15:24,598 INFO  [AMQConnection] Connected with ProtocolHandler Version:0-10
11:15:24,599 INFO  [AMQSession] Created session:org.apache.qpid.client.XASessionImpl@23d48279
11:15:24,751 ERROR [[QpidTestServlet]] Servlet.service() for servlet QpidTestServlet threw exception
java.lang.NullPointerException
	at org.apache.qpid.ra.QpidRASession.createProducer(QpidRASession.java:1191)
	at qpid.jca.example.web.QpidTestServlet.doPost(QpidTestServlet.java:96)
	at qpid.jca.example.web.QpidTestServlet.doGet(QpidTestServlet.java:81)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183)
	at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95)
	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:599)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451)
	at java.lang.Thread.run(Thread.java:679)

Expected results:


Additional info:

Comment 1 Weston M. Price 2011-09-01 13:57:08 UTC
I need more information. Please send the configuration you are using for this particular example.

Comment 2 Jiri Sedlacek 2011-09-01 14:51:39 UTC
No special configuration is needed, just :

install eap-5.1.1, 
deploy jca adapter, 
configure build.xml in example directory to use correct jboss server, profile and mrg url
run ant deploy-ds
run ant deploy-web
open in the browser http://<host>:<port>/qpid-jcaex-web/qpid

Comment 3 Weston M. Price 2011-09-01 14:55:11 UTC
'configure build.xml in example directory to use correct jboss server, profile
and mrg url'

This is what I need, as well as the *-ds.xml file you are using and any modifications you may have made to web.xml.

Comment 4 Weston M. Price 2011-09-01 14:57:43 UTC
I believe I see the issue: 

This is referenced in BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=722614

This is fixed in the latest code in GitHub but has yet to be integrated in the new packages.

Comment 5 Jiri Sedlacek 2011-09-01 15:06:43 UTC
Thanks, closing this one.

*** This bug has been marked as a duplicate of bug 722614 ***


Note You need to log in before you can comment on or make changes to this bug.