Bug 734033 - deleteUser API call fails: {"errors":["private method `can_be_deleted?' called for #<User:0x7f39ab28ee20>"]}>
Summary: deleteUser API call fails: {"errors":["private method `can_be_deleted?' calle...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-29 09:32 UTC by Garik Khachikyan
Modified: 2015-01-04 21:58 UTC (History)
2 users (show)

Fixed In Version: katello-0.1.72-1~24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:59 UTC


Attachments (Terms of Use)

Description Garik Khachikyan 2011-08-29 09:32:20 UTC
Description of problem:
Before the latest bits the delete user API call was working. Now it starts failing with:
{"errors":["private method `can_be_deleted?' called for #<User:0x7f39ab28ee20>"]}>

The same is for cli call:

Version-Release number of selected component (if applicable):
katello-0.1.71-1.git.0.7bdb786.fc15.noarch

How reproducible:
always on the latest version

Steps to Reproduce:
1.prepare a user
2.call: curl -k -s -u admin:admin -H "Accept: application/json" -X DELETE https://<katello>:3000/api/users/3
3.
  
Actual results:
fails with: private method `can_be_deleted?' called for #<User:0x7f39ab4f00b0>

Expected results:
no failures, user should be deleted

Additional info:

Comment 1 Ivan Necas 2011-08-29 13:13:46 UTC
Fixed in commit 020bc22215517a5

Comment 2 Garik Khachikyan 2011-09-23 11:27:37 UTC
# VERIFIED

Now on both: API & CLI side the delete user action goes fine. User gets removed.

Checked against: katello-cli-0.1.10-1.git.278.85760dc.el6.noarch

Comment 5 Mike McCune 2013-08-16 18:05:30 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.