Bug 734034 - Saved search name should be removed from search bar after user deletes it
Saved search name should be removed from search bar after user deletes it
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-29 05:34 EDT by Sunil Kondkar
Modified: 2012-02-07 14:21 EST (History)
2 users (show)

See Also:
Fixed In Version: 4,1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:21:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (52.16 KB, image/png)
2011-08-29 05:35 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2011-08-29 05:34:42 EDT
Description of problem:

If user deletes a saved search using the trash icon, a message appears that the saved search is deleted. The search bar still displays the saved search name and user can click in the editable text field to edit the saved search name which results in a NullPointerException.

Version-Release number of selected component (if applicable):
Build#356 (Version: 4.1.0-SNAPSHOT Build Number: a98c893)
Browser: Firefox 3.6.3

How reproducible:

Always

Steps to Reproduce:

1. Login to RHQ
2. Navigate to 'Inventory->Servers'
3. Enter in the search bar: type=cron
4. Press Enter.
5. Click on the on the star in the search box.
6. Enter the name for saved search in the editable text field.
7. Press Enter.
8. Click on the down arrow on the right in the search box.
9. Click on the trash icon for the saved search row item.
((We need to click on the trash icon by selecting the saved search row twice due to the existing Bug#733487)
10. It displays the message 'Successfully deleted saved search'.
11. Observe that the search bar still displays the saved search name.

(Please refer the screenshot)

12. Click on the saved search name in the editable text field and rename it.
13. It displays the message 'Failed to rename saved search with name' in the UI and displays a 'NullPointerException'

Actual results:

Saved search name is displayed in the search bar after user deletes it.

Expected results:

Saved search name should be removed from search bar after user deletes it.

Additional info:
Comment 1 Sunil Kondkar 2011-08-29 05:35:23 EDT
Created attachment 520327 [details]
Screenshot
Comment 2 Jay Shaughnessy 2011-08-29 15:38:25 EDT
master commit 5d9aa72083fc7e364735f26cf22c8995293b2838
Comment 3 Sunil Kondkar 2011-08-30 05:18:27 EDT
Verified on build#364 (Version: 4.1.1-BETA1 Build Number: 6db75f8)

Saved search name is removed from search bar after user deletes it. 

Marking as verified.
Comment 4 Mike Foley 2012-02-07 14:21:26 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.