Bug 734039 - include the latest libblkid in dump
Summary: include the latest libblkid in dump
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dump
Version: 5.8
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 09:50 UTC by Cedric Buissart 🐶
Modified: 2018-11-14 10:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, dump was linked against the libblkid library, which processed many device-mapper devices inefficiently. With this update, dump has been rebuilt against an updated version of the libblkid library, and it is now able to process many device-mapper devices efficiently.
Clone Of:
Environment:
Last Closed: 2011-11-29 16:21:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1502 normal SHIPPED_LIVE dump bug fix update 2011-11-29 21:20:02 UTC
Red Hat Knowledge Base (Legacy) 61859 None None None Never

Description Cedric Buissart 🐶 2011-08-29 09:50:10 UTC
>> Description of problem:

libblkid has recently been patch to improve performance when facing a lot of device-mapper devices :
bz672985 - blkid runs very slow with many dm devices and a large blkid.tab file

Without this patch, blkid loops on ioctl'ing device-mapper for hours.


Dump has static compilation against liblkid library. 
Extract of compiling dump from source RPM :
[...]
checking for blkid/blkid.h... yes
checking for blkid_get_devname in -lblkid... yes
[...]
gcc -static -o dump [...] -lblkid [...]
[...]

It should simply be recompiled to get the patched library.


=> With a simple recompilation of the dump RPM with the current libblkid (e2fsprogs), we have gone from 33 minutes down to 9 seconds for dumping a small file.


Version-Release number of selected component (if applicable):

any

>> How reproducible:

100%, but you need a proper environment to reproduce the issue (apparently : boot on SAN with many multipath is the most affected).

>> Steps to Reproduce:
1. get a boot on SAN machine, with ~100 multipath devices
2. dump
3. wait
  
>> Actual results:

wait, again and again. stracing, you will see a huge number of ioctl to device-mapper.

>> Expected results:

faster dumping

>> Additional info:
:-)

Comment 8 Petr Kovar 2011-10-05 13:17:56 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, dump was linked against the libblkid library, which processed many device-mapper devices inefficiently. With this update, dump has been rebuilt against an updated version of the libblkid library, and it is now able to process many device-mapper devices efficiently.

Comment 13 errata-xmlrpc 2011-11-29 16:21:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1502.html


Note You need to log in before you can comment on or make changes to this bug.