Bug 734048 - E-D-S converts spaces or '%20' in CalDav URIs to '%2520'
E-D-S converts spaces or '%20' in CalDav URIs to '%2520'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
6.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
: Patch
Depends On:
Blocks: 670971 782183 840699
  Show dependency treegraph
 
Reported: 2011-08-29 06:28 EDT by David Jaša
Modified: 2013-02-21 05:21 EST (History)
8 users (show)

See Also:
Fixed In Version: evolution-data-server-2.28.3-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:21:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
eds patch (1.20 KB, patch)
2011-08-29 07:14 EDT, Milan Crha
no flags Details | Diff

  None (edit)
Description David Jaša 2011-08-29 06:28:56 EDT
Description of problem:
SSIA, remote CalDav calendars are inaccessible beause of the bug.

Version-Release number of selected component (if applicable):
evolution-data-server-2.28.3-15.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. set up Evolution to use remote CalDav calendar with space in URI
2. verify that uri in <source> element in /apps/evolution/calendar/sources contains ' ' or '%20'
3. kill all evolution processes, run 'CALDAV_DEBUG=all /usr/libexec/evolution-data-server-2.28'
4. run evolution
  
Actual results:
path passed to server has space/'%20' replaced to '%2520' string

Expected results:
URI is passed with '%20'

Additional info:
Comment 2 RHEL Product and Program Management 2011-08-29 06:47:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Milan Crha 2011-08-29 07:14:03 EDT
Created attachment 520354 [details]
eds patch

for evolution-data-server CalDAV calendar backend;

This helped me. I have written that space as a space (decoded), in calendar Preferences URI and it is properly used in CalDAV backend, with this patch.
Comment 4 David Jaša 2011-08-29 09:11:13 EDT
Patch in comment 3 fixed the issue for me.
Comment 6 Suzanne Yeghiayan 2012-02-14 18:14:38 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 Suzanne Yeghiayan 2012-03-07 16:27:37 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 14 Milan Crha 2012-08-08 01:03:43 EDT
Hmm, this is dupe of bug #692658, or vice versa.
Comment 18 errata-xmlrpc 2013-02-21 05:21:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0410.html

Note You need to log in before you can comment on or make changes to this bug.