Bug 734067 - Wiping volumes has side effect of changing the volume format for non-raw volumes
Summary: Wiping volumes has side effect of changing the volume format for non-raw volumes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Osier Yang
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 11:14 UTC by Nan Zhang
Modified: 2011-11-10 21:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-10 21:31:32 UTC


Attachments (Terms of Use)

Description Nan Zhang 2011-08-29 11:14:10 UTC
Description of problem:
the volume data should be erased, but can not change its format.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-6.el6.x86_64

How reproducible:
always

Steps to Reproduce:
# qemu-img info /var/lib/libvirt/images/rhel6.img 
image: /var/lib/libvirt/images/rhel6.img
file format: qcow2
virtual size: 512K (524288 bytes)
disk size: 392K
cluster_size: 65536

# virsh vol-wipe rhel6.img --pool default
Vol rhel6.img wiped

# qemu-img info /var/lib/libvirt/images/rhel6.img 
image: /var/lib/libvirt/images/rhel6.img
file format: raw
virtual size: 512K (524288 bytes)
disk size: 0
  
Actual results:
Be changed from qcow2 to raw format after volume wiped.

Expected results:
Should be kept qcow2 format after volume wiped.

Additional info:

Comment 2 Dave Allan 2011-09-06 18:49:18 UTC
Since wiping the volume destroys all the data in it, the volume is raw because the qcow metadata has been removed.  This is behavior by design, so I am closing as NOTABUG.

Comment 3 Eric Blake 2011-09-07 14:36:25 UTC
Should virsh vol-wipe add a new flag that wipes the contents, but then restores enough qcow2 metadata that the file is back to a blank qcow2 volume?

Comment 4 Dave Allan 2011-09-08 15:43:40 UTC
Not a bad RFE, but nobody's clamoring for it.

Comment 5 Nan Zhang 2011-09-08 19:24:26 UTC
Eric,
Thanks for your inputs!

QE requests this feature support, so re-open this BZ to ASSIGNED.

Comment 6 Daniel Berrangé 2011-09-12 08:34:47 UTC
IMHO this is a bug, not an RFE.

Wiping a volume should only be wiping the data, not the file format info. The problem is that the current code is not paying attention to the file format when wiping data, it just blindly truncates the file to zero bytes. For non-raw formats, we should run 'qemu-img create' again after truncation to ensure the original file format structure is preserved.


Note You need to log in before you can comment on or make changes to this bug.