Bug 734074 - Mutilated xsane preview window if started for a second time in the same gnome session
Summary: Mutilated xsane preview window if started for a second time in the same gnome...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 11:40 UTC by Joachim Backes
Modified: 2014-04-19 11:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-14 11:42:41 UTC


Attachments (Terms of Use)
mutilated xsane preview window (4.52 MB, application/octet-stream)
2011-08-29 11:40 UTC, Joachim Backes
no flags Details
mutilated preview window - renamed to ...gif (4.52 MB, image/gif)
2011-08-29 11:47 UTC, Joachim Backes
no flags Details
mutilated preview window (15.69 KB, image/jpeg)
2011-08-29 11:50 UTC, Joachim Backes
no flags Details
.xsession-errors (21.37 KB, application/octet-stream)
2011-08-30 11:03 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2011-08-29 11:40:32 UTC
Created attachment 520361 [details]
mutilated xsane preview window

Description of problem:
If running xsane with the preview window, then exititing from xsane and starting it a second time shows the preview window rather mutilated.

I have to logout and relogin for getting an intact preview window.

My desktop: gnome3 (gnome-shell)

Version-Release number of selected component (if applicable):
xsane-0.998-4.fc16.x86_64

How reproducible:

always
Steps to Reproduce:
1.Start xsane and show preview window
2.end xsane
3.Start xsane again
  
Actual results:
damaged preview window

Expected results:
clean preview window

Additional info:

Comment 1 Joachim Backes 2011-08-29 11:47:22 UTC
Created attachment 520362 [details]
mutilated preview window - renamed to ...gif

Attached file renamed.

Comment 2 Joachim Backes 2011-08-29 11:50:15 UTC
Created attachment 520366 [details]
mutilated preview window

Attaching the preview window as jpg file

Comment 3 Joachim Backes 2011-08-29 11:56:42 UTC
Testing the same in a *xfce* session:

After exiting and starting xsane again, the preview window remains presented (in a correct manner). 

It seems the problem is a gnome-shell problem.

Comment 4 Joachim Backes 2011-08-29 14:31:05 UTC
I get rid from the described behaviour by starting xsane inside a terminal window and not by the gnome-shell favorite bar.

Comment 5 Nils Philippsen 2011-08-30 09:08:05 UTC
This is strange. Would you please attach your (possibly compressed/gzipped if needed) ~/.xsession-errors to this ticket? Thanks.

Comment 6 Nils Philippsen 2011-08-30 09:13:35 UTC
Another one: Please switch (temporarily) to forced fallback mode -- I have a hunch that this is related to GNOME3 using compositing. To do that, go to "System Settings -> System Info -> Graphics" and switch "Forced Fallback Mode" to "On". Then logout and login again, and check if xsane behaves in the same fashion. Thanks.

Comment 7 Joachim Backes 2011-08-30 11:03:06 UTC
Created attachment 520590 [details]
.xsession-errors

Comment 8 Joachim Backes 2011-08-30 11:17:01 UTC
(In reply to comment #6)
> Another one: Please switch (temporarily) to forced fallback mode -- I have a
> hunch that this is related to GNOME3 using compositing. To do that, go to
> "System Settings -> System Info -> Graphics" and switch "Forced Fallback Mode"
> to "On". Then logout and login again, and check if xsane behaves in the same
> fashion. Thanks.

In the fallback mode I can't reproduce the described behaviour. But If switching off the fallback mode and then logging in again and starting xsane (by the favorites bar),  the preview window is again mutilated.

Kind regards

JB

Comment 9 Nils Philippsen 2011-08-30 14:05:53 UTC
I'll assume that compositing triggers this broken display of the preview window then. Changing component to mutter for further investigation.

Comment 10 Joachim Backes 2011-08-30 14:26:21 UTC
Good to hear, because I have more some apps whose behaviour strongly depend on the usage of mutter or not.

Comment 11 Joachim Backes 2012-02-13 13:51:07 UTC
I cannot rproduce the described behaviour with mutter-3.2.2-1.fc16.x86_64.

Comment 12 Mark Turner 2013-01-06 20:26:22 UTC
Hi folks. I just had this error occur on my x86_64 Fedora 17 install, using mutter-3.4.1-4.fc17.x86_64:

Xsane vers:
xsane-common-0.998-12.fc17.x86_64
xsane-0.998-12.fc17.x86_64
xsane-gimp-0.998-12.fc17.x86_64

lsb_release -a
LSB Version:	:core-4.1-amd64:core-4.1-ia32:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-ia32:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-ia32:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID:	Fedora
Description:	Fedora release 17 (Beefy Miracle)
Release:	17
Codename:	BeefyMiracle

Should this bug be reopened or shall I file a new one?

Comment 13 Joachim Backes 2014-04-19 11:12:57 UTC
(In reply to Joachim Backes from comment #0)
> Created attachment 520361 [details]
> mutilated xsane preview window
> 
> Description of problem:
> If running xsane with the preview window, then exititing from xsane and
> starting it a second time shows the preview window rather mutilated.
> 
> I have to logout and relogin for getting an intact preview window.
> 
> My desktop: gnome3 (gnome-shell)
> 
> Version-Release number of selected component (if applicable):
> xsane-0.998-4.fc16.x86_64
> 
> How reproducible:
> 
> always
> Steps to Reproduce:
> 1.Start xsane and show preview window
> 2.end xsane
> 3.Start xsane again
>   
> Actual results:
> damaged preview window
> 
> Expected results:
> clean preview window
> 
> Additional info:


Same problems in F20 (xsane-0.999-12.fc20.x86_64)

Comment 14 Joachim Backes 2014-04-19 11:17:25 UTC
I forgot to say: I'm working with mutter-3.10.4-2.fc20

Comment 15 Joachim Backes 2014-04-19 11:20:20 UTC
Downgrading to mutter-3.10.4-1.fc20.x86_64 helps :-)


Note You need to log in before you can comment on or make changes to this bug.