Bug 734083 - tsclient ignores the Color depth option
Summary: tsclient ignores the Color depth option
Keywords:
Status: CLOSED DUPLICATE of bug 798631
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tsclient
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 12:21 UTC by Martin Simon
Modified: 2016-09-20 02:15 UTC (History)
1 user (show)

Fixed In Version: tsclient-2.0.2-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-05 11:28:37 UTC


Attachments (Terms of Use)

Description Martin Simon 2011-08-29 12:21:41 UTC
Description of problem:
During the creating of Windows terminal service connection is tsclient there is an option to set color depth (in Advanced Options section). But after setting this option is completely ignored - there is no flag in rdesktop command

Version-Release number of selected component (if applicable):
tsclient-2.0.2-7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start tsclient from terminal (you will see runtime messages/commands)
2. edit/create a Windows Terminal Service connection and set color depth to e.g. 8
3. start connection
  
Actual results:
the runtime command message in terminal has no mention about color depth (flag '-a' in rdesktop)

Expected results:
flag "-a" in rdesktop command and proper color depth in remote connection

Additional info:
it looks like the color depth option is no even saved - the color depth option has default value (24) every time i try to edit the connection

Comment 4 Suzanne Yeghiayan 2012-02-14 23:14:42 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 6 Ondrej Holy 2015-10-05 11:28:37 UTC
It works for me correctly with the following version:
tsclient-2.0.2-10.el6.i686

Chosen color depth is saved in:
/home/$USER/.config/tsclient/connections/*.tsc

Chosen color depth is shown in edit connection dialog.

rdesktop commandline has -a with chosen color depth. 

It seems it has been already fixed by Bug 798631.

*** This bug has been marked as a duplicate of bug 798631 ***


Note You need to log in before you can comment on or make changes to this bug.