Bug 734122 - local_boot_trigger causes is_upgrade to return true
Summary: local_boot_trigger causes is_upgrade to return true
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 13:58 UTC by Mike Burns
Modified: 2011-12-06 19:27 UTC (History)
6 users (show)

Fixed In Version: ovirt-node-2.0.2-0.3.gitcf213a7.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:27:04 UTC


Attachments (Terms of Use)
Patch (906 bytes, patch)
2011-08-30 15:08 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Mike Burns 2011-08-29 13:58:34 UTC
Description of problem:
passing the local_boot_trigger argument will cause ovirt to think that you want an upgrade.  This is due to ovirt-early matching local_boot* for upgrade

Version-Release number of selected component (if applicable):
6.2-*

How reproducible:
Always

Steps to Reproduce:
1.boot with default args + local_boot_trigger
2.system will think it's an upgrade and fail
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike Burns 2011-08-30 15:08:18 UTC
Created attachment 520624 [details]
Patch

upgrade should only be triggered when one of the following is passed:

local_boot
local_boot=*
upgrade*
ovirt_upgrade*
ovirt_local_boot*

all other options passed should not trigger upgrade.

Comment 4 errata-xmlrpc 2011-12-06 19:27:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.