This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 734138 - Exception after JAR archive undeployment
Exception after JAR archive undeployment
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.1
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Jan Martiska
Mike Foley
:
Depends On:
Blocks: rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-29 10:27 EDT by Jan Martiska
Modified: 2011-10-06 15:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-09 16:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
simple EJB jar for reproducing the error (2.70 KB, application/x-java-archive)
2011-08-29 10:28 EDT, Jan Martiska
no flags Details

  None (edit)
Description Jan Martiska 2011-08-29 10:27:31 EDT
Description of problem:
Globally uncaught exception occurs after JAR archive is undeployed from an AS instance.

Version-Release number of selected component (if applicable):
Version: 4.1.0-SNAPSHOT
Build Number: bdc6f5e
GWT Version: 2.0.4
SmartGWT Version: 2.4

Browser: Firefox 5.0
OS of system running RHQ: RHEL 6 x64

How reproducible:
100%

Steps to Reproduce:
1. Navigate to Inventory/Child resources of an imported AS instance. 
2. Create a child - deploy an EJB-jar file, for example the one from the attachment.
3. After deployment, delete this file (also from Inventory/Child resources tab)
  
Actual results:
The JAR gets successfully undeployed, but a "Globally uncaught exception" occurs in the GUI.

Expected results:
The JAR gets successfully undeployed and no exceptions are thrown.

Additional info:
myEjbJar1-1.0-SNAPSHOT.jar is attached as an example archive which causes trouble. It contains one simple EJB3 stateless bean.
Comment 1 Jan Martiska 2011-08-29 10:28:59 EDT
Created attachment 520410 [details]
simple EJB jar for reproducing the error
Comment 2 Mike Foley 2011-08-29 11:08:34 EDT
jan... dev has requested attachment of server-side stack trace from the rhq server log file.  and client-side stack trace from the message center.
Comment 3 Jan Martiska 2011-08-29 11:21:46 EDT
No error occurs in the server log or AS7 log.

stack trace from message center:

com.google.gwt.core.client.JavaScriptException:(TypeError): com_google_gwt_lang_Cast_dynamicCast__Ljava_lang_Object_2ILjava_lang_Object_2((com_smartgwt_client_util_JSOHelper_getAttributeAsObject__Lcom_google_gwt_core_client_JavaScriptObject_2Ljava_lang_String_2Ljava_lang_Object_2_ret_0 = record.com_smartgwt_client_core_JsObject_jsObj[$intern_3221], com_smartgwt_client_util_JSOHelper_getAttributeAsObject__Lcom_google_gwt_core_client_JavaScriptObject_2Ljava_lang_String_2Ljava_lang_Object_2_ret_0 === undefined ? null : com_smartgwt_client_util_JSOHelper_getAttributeAsObject__Lcom_google_gwt_core_client_JavaScriptObject_2Ljava_lang_String_2Ljava_lang_Object_2_ret_0), 663) is null stack: org_rhq_enterprise_gui_coregui_client_inventory_resource_AncestryUtil_getResourceHoverHTML__Lcom_smartgwt_client_data_Record_2ILjava_lang_String_2([object Object],0)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:136099 org_rhq_enterprise_gui_coregui_client_inventory_resource_ResourceSearchView$6_hoverHTML__Ljava_lang_Object_2Lcom_smartgwt_client_widgets_grid_ListGridRecord_2IILjava_lang_String_2(" ",[object Object],0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:136821 ("loading"," ",0,1,[object Object])@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:23641 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function (record, value, rowNum, colNum, grid) {var recordJ = com_smartgwt_client_widgets_grid_ListGridRecord_getOrCreateRef__Lcom_google_gwt_core_client_JavaScriptObject_2Lcom_smartgwt_client_widgets_grid_ListGridRecord_2(record);var valueJ = $wnd.SmartGWT.convertToJavaType(value);return hoverCustomizer.hoverHTML__Ljava_lang_Object_2Lcom_smartgwt_client_widgets_grid_ListGridRecord_2IILjava_lang_String_2(valueJ, recordJ, rowNum, colNum);}),[object Object],[object Arguments])@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:2474 ("loading"," ",0,1,[object Object])@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:2463 isc_ListGrid_cellHoverHTML("loading",0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:1557 anonymous("loading",0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:927 isc_GridRenderer__showHover("loading",0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:718 isc_GridRenderer__cellHover(0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:717 isc_c_Hover__doAction()@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:3764 isc_c_Class_fireCallback([object Object],(void 0),[object Array],[object Object],true)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:296 isc_c_Timer__fireTimeout("$ir39300")@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:1186 @http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:1181 fileName: http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html lineNumber: 136099
--- STACK TRACE FOLLOWS ---
(TypeError): com_google_gwt_lang_Cast_dynamicCast__Ljava_lang_Object_2ILjava_lang_Object_2((com_smartgwt_client_util_JSOHelper_getAttributeAsObject__Lcom_google_gwt_core_client_JavaScriptObject_2Ljava_lang_String_2Ljava_lang_Object_2_ret_0 = record.com_smartgwt_client_core_JsObject_jsObj[$intern_3221], com_smartgwt_client_util_JSOHelper_getAttributeAsObject__Lcom_google_gwt_core_client_JavaScriptObject_2Ljava_lang_String_2Ljava_lang_Object_2_ret_0 === undefined ? null : com_smartgwt_client_util_JSOHelper_getAttributeAsObject__Lcom_google_gwt_core_client_JavaScriptObject_2Ljava_lang_String_2Ljava_lang_Object_2_ret_0), 663) is null stack: org_rhq_enterprise_gui_coregui_client_inventory_resource_AncestryUtil_getResourceHoverHTML__Lcom_smartgwt_client_data_Record_2ILjava_lang_String_2([object Object],0)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:136099 org_rhq_enterprise_gui_coregui_client_inventory_resource_ResourceSearchView$6_hoverHTML__Ljava_lang_Object_2Lcom_smartgwt_client_widgets_grid_ListGridRecord_2IILjava_lang_String_2(" ",[object Object],0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:136821 ("loading"," ",0,1,[object Object])@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:23641 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function (record, value, rowNum, colNum, grid) {var recordJ = com_smartgwt_client_widgets_grid_ListGridRecord_getOrCreateRef__Lcom_google_gwt_core_client_JavaScriptObject_2Lcom_smartgwt_client_widgets_grid_ListGridRecord_2(record);var valueJ = $wnd.SmartGWT.convertToJavaType(value);return hoverCustomizer.hoverHTML__Ljava_lang_Object_2Lcom_smartgwt_client_widgets_grid_ListGridRecord_2IILjava_lang_String_2(valueJ, recordJ, rowNum, colNum);}),[object Object],[object Arguments])@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:2474 ("loading"," ",0,1,[object Object])@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html:2463 isc_ListGrid_cellHoverHTML("loading",0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:1557 anonymous("loading",0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:927 isc_GridRenderer__showHover("loading",0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:718 isc_GridRenderer__cellHover(0,1)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Grids.js:717 isc_c_Hover__doAction()@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:3764 isc_c_Class_fireCallback([object Object],(void 0),[object Array],[object Object],true)@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:296 isc_c_Timer__fireTimeout("$ir39300")@http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:1186 @http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:1181 fileName: http://stacks4.mw.lab.eng.bos.redhat.com:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/682C6F277ADF5AEC320171959D1BDAD8.cache.html lineNumber: 136099
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_AncestryUtil_getResourceHoverHTML__Lcom_smartgwt_client_data_Record_2ILjava_lang_String_2(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_ResourceSearchView$6_hoverHTML__Ljava_lang_Object_2Lcom_smartgwt_client_widgets_grid_ListGridRecord_2IILjava_lang_String_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.isc_ListGrid_cellHoverHTML(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.isc_GridRenderer__showHover(Unknown source:0)
    at Unknown.isc_GridRenderer__cellHover(Unknown source:0)
    at Unknown.isc_c_Hover__doAction(Unknown source:0)
    at Unknown.isc_c_Class_fireCallback(Unknown source:0)
    at Unknown.isc_c_Timer__fireTimeout(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
Comment 4 Charles Crouch 2011-08-29 11:27:15 EDT
What version of AS was this against?
Does it also occur when deleting other newly created resources, e.g.wars/ears
Comment 5 Jan Martiska 2011-08-29 12:27:31 EDT
AS version: 7.0.0.Final

Hmm, I tried the same with WARs/EARs and it worked, furthermore the issue with JARs disappeared somehow. Don't know how that is possible, as it looks like some javascript problem and it doesn't affect functionality, it might have been some minor glitch concerning GWT compatibility with Firefox 5. 

If you are not encountering this problem, I think we could ignore and close it as NOTABUG? Do you agree?
Comment 6 Charles Crouch 2011-08-29 18:39:06 EDT
Pushing to ON_QA to have a different set of eyes try to reproduce
Comment 7 Mike Foley 2011-09-09 16:03:51 EDT
cannot repro.  documenting the successful deployment and undeployment.  

5:42:05,763 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) Starting deployment of "myEjbJar1-1.0-SNAPSHOT.jar"
15:42:05,928 INFO  [org.jboss.as.ejb3.deployment.processors.EjbJndiBindingsDeploymentUnitProcessor] (MSC service thread 1-1) JNDI bindings for session bean named GreetingBean in deployment unit deployment "myEjbJar1-1.0-SNAPSHOT.jar" are as follows:

	java:global/myEjbJar1-1.0-SNAPSHOT/GreetingBean!cz.wraychus.myejbjar1.GreetingBean
	java:app/myEjbJar1-1.0-SNAPSHOT/GreetingBean!cz.wraychus.myejbjar1.GreetingBean
	java:module/GreetingBean!cz.wraychus.myejbjar1.GreetingBean
	java:global/myEjbJar1-1.0-SNAPSHOT/GreetingBean
	java:app/myEjbJar1-1.0-SNAPSHOT/GreetingBean
	java:module/GreetingBean

15:42:06,228 INFO  [org.jboss.as.server.controller] (HttpManagementService-threads - 2) Deployed "myEjbJar1-1.0-SNAPSHOT.jar"
15:43:09,257 INFO  [org.jboss.as.server.controller] (HttpManagementService-threads - 2) Undeployed "myEjbJar1-1.0-SNAPSHOT.jar"
15:43:09,269 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) Stopped deployment myEjbJar1-1.0-SNAPSHOT.jar in 18ms
15:49:25,047 WARN  [org.jboss.as.controller] (HttpManagementService-threads - 4) Operation ("read-attribute") failed - address: ([
    {"subsystem" => "web"},
    {"connector" => "terst"}
])
15:49:25,050 WARN  [org.jboss.as.controller] (HttpManagementService-threads - 4) Operation ("read-attribute") failed - address: ([
    {"subsystem" => "web"},
    {"connector" => "terst"}
])

Note You need to log in before you can comment on or make changes to this bug.