Bug 734141 - Unable to add system properties for AS
Unable to add system properties for AS
Status: CLOSED DUPLICATE of bug 708332
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2011-08-29 10:39 EDT by Jan Martiska
Modified: 2012-02-08 10:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-08 10:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2011-08-29 10:39:01 EDT
Description of problem:
Unable to add system properties for AS 7.0.0.Final instance.

Version-Release number of selected component (if applicable):
Version: 4.1.0-SNAPSHOT
Build Number: bdc6f5e
GWT Version: 2.0.4
SmartGWT Version: 2.4

Browser: Firefox 5.0
OS of system running RHQ: RHEL 6 x64

How reproducible:
100%

Steps to Reproduce:
1. Import a running AS7 instance 
2. Navigate to Inventory / Connection settings of the imported instance
3. Click the green "plus" button to add new system property for AS runtime
4. Input any key and value, press OK button
  
Actual results:
No new entry occurs in the GUI. Did not check yet, whether the variable would actually occur for the AS instance.

Expected results:
New system property for the AS runtime should be visible in the GUI in "Inventory / Connection settings" tab

Additional info:
Comment 1 Charles Crouch 2011-08-29 18:38:52 EDT
This smells fishy. This doesn't sound right that configuration for the AS 
itself should be happening via the Inventory/Connection subtab.

I'd like to know if this is a GUI widge thing or a JBAS7 plugin thing. Jan can 
you find another resource which uses the 'green "plus" button' to change its 
configuration and make sure that works.
Comment 2 Jan Martiska 2011-08-30 02:43:03 EDT
Found and tried two other similar widgets (AS: Inventory/Connection settings/Events and also logging at Agent's level), these two work. Tried with the same Firefox 5 browser.. Additionally, I was unable to find any errors concerning this in the logs.

Btw. yes, I agree that setting properties under connection settings is somewhat weird.
Comment 3 Heiko W. Rupp 2012-02-08 10:20:44 EST
should work see Bug 708332 -- lets use the other one to track

*** This bug has been marked as a duplicate of bug 708332 ***

Note You need to log in before you can comment on or make changes to this bug.