Bug 734170 - New syslinux theme for F16 DVD
New syslinux theme for F16 DVD
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: 734169
  Show dependency treegraph
 
Reported: 2011-08-29 11:43 EDT by Máirín Duffy
Modified: 2013-07-04 08:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: lorax-16.4.4-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-25 21:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
New, clean syslinux config for the DVD (2.08 KB, text/plain)
2011-08-30 12:27 EDT, Máirín Duffy
no flags Details
splash.png image (2.45 KB, image/png)
2011-08-30 12:35 EDT, Máirín Duffy
no flags Details
Screenshot showing the syslinux.config looking as-designed (184.75 KB, image/jpeg)
2011-08-30 12:39 EDT, Máirín Duffy
no flags Details
Updated new/clean syslinux.config for the DVD (2.08 KB, text/plain)
2011-08-30 13:10 EDT, Máirín Duffy
no flags Details
New/clean syslinux.config for the DVD (2.57 KB, application/octet-stream)
2011-08-30 14:29 EDT, Máirín Duffy
no flags Details
Screenshot showing the syslinux.config looking as-designed (601.54 KB, image/jpeg)
2011-08-30 14:53 EDT, Máirín Duffy
no flags Details
New/clean syslinux.config for the DVD (2.81 KB, text/plain)
2011-08-30 15:03 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2011-08-29 11:43:41 EDT
Let's update the syslinux theme for DVDs with the newer & cleaner design. lorax-treebuilder then needs a new theme template to apply to Fedora 16.

I'll assign the bug to myself initially so I can create the template for you, then I'll reassign to the default component owner.
Comment 1 Máirín Duffy 2011-08-30 12:27:54 EDT
Created attachment 520640 [details]
New, clean syslinux config for the DVD

I grabbed the syslinux config from the lorax git repo and modified it. I tested it using a live usb stick and it seemed to look good.
Comment 2 Máirín Duffy 2011-08-30 12:35:36 EDT
Created attachment 520642 [details]
splash.png image
Comment 3 Máirín Duffy 2011-08-30 12:37:08 EDT
Hi Martin, I'm reassigning this to you to update the file now. I'll attach some screenshots too so you can see how it will look.
Comment 4 Máirín Duffy 2011-08-30 12:39:56 EDT
Created attachment 520643 [details]
Screenshot showing the syslinux.config looking as-designed
Comment 5 Máirín Duffy 2011-08-30 13:10:52 EDT
Created attachment 520651 [details]
Updated new/clean syslinux.config for the DVD

I forgot to comment out the local boot option. We'd discussed this last time around in #anaconda and had decided it was not necessary since most people reboot and pull the stick/dvd to achieve this anyway.
Comment 6 Máirín Duffy 2011-08-30 14:29:25 EDT
Created attachment 520664 [details]
New/clean syslinux.config for the DVD

added troubleshooting submenu
Comment 7 Máirín Duffy 2011-08-30 14:53:20 EDT
Created attachment 520667 [details]
Screenshot showing the syslinux.config looking as-designed
Comment 8 Máirín Duffy 2011-08-30 15:03:54 EDT
Created attachment 520669 [details]
New/clean syslinux.config for the DVD

(added clear option)
Comment 9 Adam Williamson 2011-09-02 15:11:46 EDT
Discussed at 2011-09-02 NTH review meeting. Accepted as NTH: it's a slightly
dangerous change but we're confident we can test it, and the cosmetic benefit
is significant.
Comment 10 Martin Gracik 2011-09-05 04:45:22 EDT
Where did you get the original syslinux.cfg file from? I'm concerned with the @ROOT@ variable inside. The syslinux.cfg that is in anaconda, which we are providing, has no @ROOT@.
Comment 12 Martin Gracik 2011-09-07 07:53:01 EDT
I thought so. The treebuilder branch is not yet used to do f16 composes. But I'll do the necessary changes.
Comment 13 Adam Williamson 2011-09-16 00:46:38 EDT
so, RC1 was a bit of a swing-and-a-miss: the bootloader background is plain black on all lives and the DVD.
Comment 14 Martin Gracik 2011-09-16 03:09:03 EDT
The version this will be fixed in was not built yet, I'm just going to make a new build today, so the images you have don't have this fix.
Comment 15 Fedora Update System 2011-09-16 07:56:16 EDT
lorax-16.4.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.3-1.fc16
Comment 16 Fedora Update System 2011-09-17 15:32:36 EDT
Package lorax-16.4.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-16.4.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lorax-16.4.3-1.fc16
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2011-09-19 09:37:07 EDT
lorax-16.4.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.4-1.fc16
Comment 18 Fedora Update System 2011-09-25 21:40:52 EDT
lorax-16.4.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.