Bug 734176 - Postfix - a standard, FHS-compliant place for virtual user mailboxes
Summary: Postfix - a standard, FHS-compliant place for virtual user mailboxes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Deployment_Guide
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Stephen Wadeley
QA Contact: ecs-bugs
URL: http://www.postfix.org/VIRTUAL_README...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 15:53 UTC by Jaroslav Škarvada
Modified: 2015-04-07 07:28 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 216687
Environment:
Last Closed: 2015-04-07 07:28:59 UTC


Attachments (Terms of Use)

Description Jaroslav Škarvada 2011-08-29 15:53:36 UTC
+++ This bug was initially created as a clone of Bug #216687 +++

Description of problem:

Hello,

IMHO, the postfix documentation should provide a standard, FHS-compliant place
on the filesystem to put the virtual user mailboxes (mbox *or* Maildir). Please
see http://www.postfix.org/VIRTUAL_README.html#virtual_mailbox: I mean the value
for the virtual_mailbox_base parameter (and subdirectories for it).

This should be default option in the main.cf file provided in distro.

The FHS standard v2.3, paragraph 5.11 states that /var/mail is the default
place, but explicitly says that "user mailboxes files in this location must be
stored in the standard UNIX mailbox format". IMHO, it is unclear if this
excludes only proprietary mailbox formats or Maildir as well. 

Given the fact that the distro is now SELinux-enabled by default and dovecot is
the default IMAP server, the proposed directory should meet other requirements too:

- dovecot (or other imap servers) must be able to pick-up messages from there
(permissions related matters);
- it should not matter if the virtual mailboxes share the same UID/GID for all
users or if these are different;
- documentation should explictly say which preconfigured system user/group will
own the virtual mailboxes, in case it's a common one;
- spamassassin, amavisd-new, pyzor, clamav and other programs that eventually
need to access that directory should be able to do it;
- the configuration should work when SELinux is in enforcing mode, with an
unmodified (default) SELinux policy.


Regards,
Razvan   


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Postfix documentation only sugest a place for virtual user mailboxes. In a
SELinux-enabled environment, there are often interoperability problems between
the various components involved in an e-mail system, requiring various
permissions hacks or disabling SELinux.

Expected results:
A FHS-compliant place for those mailboxes should be provided and suggested both
in documentation and in Postfix's default main.cf. Postfix documentation should
agree on this with POP3 server's documentation. SELinux default policy should
take into account the proposed usage for this directory, allowing the various
programs to acces it apropriately.

A preconfigured system user/group should exist as a common owner for the virtual
mailboxes, if administrator wants to use a common one. The docs should
explicitly indicate this preconfigured system user in an RH-compliant distro.


Additional info:

--- Additional comment from kwade@redhat.com on 2006-11-21 17:25:44 CET ---

Reassigning to the postfix maintainer in the Fedora Core component.  Postfix
documentation comes from upstream with the rest of the source, so it is not
anything Fedora Documentation has control over.

I don't know anything about the technical feasibility of this proposal, but I do
know that a patch accompanying the suggestion should help acceptance from the
Postfix team.

--- Additional comment from kwade@redhat.com on 2006-12-28 16:47:38 CET ---

Seems that reassigning to the component didn't reassign to that component owner;
fixed by assigning to twoerner@redhat.com.

--- Additional comment from razvan.sandu@mobexpert.ro on 2007-07-12 20:24:45 CEST ---

Hello,

Are there any news about this ?

Răzvan



--- Additional comment from tfu@redhat.com on 2010-06-29 03:46:19 CEST ---

requested by anross

--- Additional comment from mlichvar@redhat.com on 2010-09-21 14:22:26 CEST ---

Is there a directory which selinux-policy expects to have the virtual mailboxes?

Does dovecot or spamassassin have a default?

--- Additional comment from mhlavink@redhat.com on 2010-09-21 15:17:26 CEST ---

(In reply to comment #5)
> Is there a directory which selinux-policy expects to have the virtual
> mailboxes?
> 
> Does dovecot or spamassassin have a default?

dovecot defaults for system users so it has to be explicitly specified for virtual users. Mail storage if not specified is looked for at standard places : /var/mail, ~/mail and so on. If nothing is specified and nothing already exists dovecot complains to log and exits

--- Additional comment from dwalsh@redhat.com on 2010-10-04 17:15:41 CEST ---

Labels exist in RHEL5.6 for /var/mail and /var/spool/mail

--- Additional comment from jskarvad@redhat.com on 2011-08-29 17:52:10 CEST ---

Changing severity to 'medium', because this issue doesn't full-fill the 'high' definition, that is defined as:
> Problem due to crashes, loss of data, severe memory, leak, etc.

Cloning to RHEL-6.

Comment 2 RHEL Product and Program Management 2011-08-29 16:28:12 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Jaroslav Škarvada 2012-06-28 15:02:37 UTC
Reassigning to Deployment_guide according to bug 216687 comment 12.

Comment 7 Stephen Wadeley 2015-03-24 15:07:43 UTC
Hello

As per https://bugzilla.redhat.com/show_bug.cgi?id=216687#c18, a Red Hat Knowledgebase article was created.

How to Configure a System to Manage Multiple Virtual Mailboxes Using Postfix and Dovecot - Red Hat Customer Portal - https://access.redhat.com/articles/209683


I will link to that from the guide.


Thank you

Comment 8 Stephen Wadeley 2015-04-07 07:28:59 UTC
Fixed in version:

Red_Hat_Enterprise_Linux-Deployment_Guide-6-en-US-6-5.2

See: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/s2-email-useful-websites.html

Thank you


Note You need to log in before you can comment on or make changes to this bug.