Bug 734200 - Doesn't install, broken dependencies after update.
Summary: Doesn't install, broken dependencies after update.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 17:49 UTC by solanum
Modified: 2011-09-07 14:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 14:52:00 UTC


Attachments (Terms of Use)

Description solanum 2011-08-29 17:49:00 UTC
Not sure this belongs here. I didnt see it reported after searching. Please disregard if I didn't find it. 

I didn't think I should try skipping i386. 

[root@oinik so]# yum install gcc --skip-broken
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.6.1-8.fc16 will be installed
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.6.1-8.fc16.x86_64
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.14.90-4 will be installed
--> Processing Dependency: glibc-headers = 2.14.90-4 for package: glibc-devel-2.14.90-4.x86_64
--> Processing Dependency: glibc = 2.14.90-4 for package: glibc-devel-2.14.90-4.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.14.90-4.x86_64
--> Running transaction check
---> Package glibc.i686 0:2.14.90-4 will be installed
--> Processing Dependency: glibc-common = 2.14.90-4 for package: glibc-2.14.90-4.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.14.90-4.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.14.90-4.i686
---> Package glibc-headers.x86_64 0:2.14.90-4 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.14.90-4 will be installed
--> Processing Dependency: glibc-common = 2.14.90-4 for package: glibc-2.14.90-4.i686
---> Package nss-softokn-freebl.i686 0:3.12.10-4.fc16 will be installed
--> Running transaction check
---> Package gcc.x86_64 0:4.6.1-8.fc16 will be installed
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.6.1-8.fc16.x86_64

Packages skipped because of dependency problems:
    gcc-4.6.1-8.fc16.x86_64 from updates-testing
    glibc-2.14.90-4.i686 from fedora
    glibc-devel-2.14.90-4.x86_64 from fedora
    glibc-headers-2.14.90-4.x86_64 from fedora
    nss-softokn-freebl-3.12.10-4.fc16.i686 from fedora

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Aravind vijayan 2011-09-07 10:05:28 UTC
 yum --enablerepo=updates install gcc

This may help you...

And i get this form:http://www.fedoraforum.org/forum/showthread.php?t=254186 where they discussed the same problem.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 solanum 2011-09-07 14:41:49 UTC
You can close if it is a known issue or a duplicate of something. I had to reinstall for -other- reasons, so i installed the dev tools group this time and that seems to have fixed the issue. But I just wanted it noted that it wasn't working with a typical desktop install.


Note You need to log in before you can comment on or make changes to this bug.