Bug 73421 - Application's icon can't be moved on the panel
Application's icon can't be moved on the panel
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 11:22 EDT by Manfred Hollstein
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-28 15:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2002-09-04 11:22:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020623

Description of problem:
I started rhn-applet via command line (there doesn't appear a menu
entry for it?), configured it, then saved the session to ensure it'll
be started upon next login.
Due to the app responding to a single mouse-click, there is no way I
can drag the icon on the panel to another location.

Version-Release number of selected component (if applicable):
2.0.0-24

How reproducible:
Always

Steps to Reproduce:
1.Start rhn-applet-gui
2.Configure it
3.Left- or middle-click and try to drag it to another location
	

Actual Results:  When the left/middle button is clicked, the dialog box is popping
up immediately.

Expected Results:  Using the middle button the icon should be moveable around
the panel.

Additional info:

With other icons on the panel it is possible to drag them using the
middle mouse button. I understand that rhn-applet isn't actually an
applet anymore, but it should provide a "Move" entry in its context
menu then (right button).
Comment 1 Daniel Veillard 2003-09-28 15:16:28 EDT
The rhn-applet is not directly included in the task bar but via the 
system tray. You cannot move the applet, you can only move the system tray.
This is a limitation of the embedding infrastructure, and cannot be fixed
byt the applet itself.


Daniel

Note You need to log in before you can comment on or make changes to this bug.