This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 734247 - [system-config-printer] enters endless loop "Got password callback" at "Describe Printer" stage
[system-config-printer] enters endless loop "Got password callback" at "Descr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-cups (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 742572 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-29 17:12 EDT by Joachim Frieben
Modified: 2011-10-04 17:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-cups-1.9.59-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-04 17:11:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2011-08-29 17:12:04 EDT
Description of problem:
When setting up an HP LaserJet 4000 connected to /dev/lp0 under current F16, system-config-printer ist stuck at stage "Describe Printer". Running in debug mode, an endless loop of "Got password callback" messages is returned to the shell after entering the root password in order to proceed.

Version-Release number of selected component (if applicable):
system-config-printer-1.3.6-1.fc16

How reproducible:
Always.

Steps to Reproduce:
1. Run system-config-printer.
2. Enter all required information until section "Describe Printer" is reached.
3. Enter printer name, description, and location, press "Apply" and enter root password.
  
Actual results:
Application just sits there, and nothing happens. "Got password callback" messages are returned endlessly to the shell.

Expected results:
system-config-printer completes printer configuration.

Additional info:
None.
Comment 1 Fedora Update System 2011-10-03 13:23:33 EDT
python-cups-1.9.59-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-cups-1.9.59-1.fc16
Comment 2 Tim Waugh 2011-10-04 05:00:02 EDT
*** Bug 742572 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2011-10-04 17:11:16 EDT
python-cups-1.9.59-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.