Bug 734287 - mouse hangs and then restarts on firefox and thunderbird after new kernel update
Summary: mouse hangs and then restarts on firefox and thunderbird after new kernel update
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 14
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 01:31 UTC by rmknox
Modified: 2012-05-03 14:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-03 14:49:39 UTC


Attachments (Terms of Use)
log (1.12 MB, text/plain)
2011-09-01 04:23 UTC, rmknox
no flags Details

Description rmknox 2011-08-30 01:31:07 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.19) Gecko/20110429 Fedora/2.0.14-1.fc14 SeaMonkey/2.0.14

I am sending from seamonkey because almost can not use firefox and thunderbird
fedora 2.6.35.14-95.fc14.i686
firefox 3.6.20
thunderbird 3.1.12

tried both mouseport mouse and usb mouse - same
mouse works - then hangs maybe 5 seconds  - then after a while it works

oops just happened in seamonkey but i had firefox and thunderbird open. closed both and now seamonkey working ok.

Reproducible: Always

Comment 1 rmknox 2011-08-30 03:31:14 UTC
i stopped all tasks and then ran the solitare game - and i get the same result

mouse works - and then freezes for perhaps 5 seconds - and then works.

just for the hell of it I will boot a win98se disk and establishe whether it happens there (my hardware) or on ly ion fedora

Comment 2 rmknox 2011-08-30 03:51:46 UTC
win 98 works great but to get here i had to use the tab key cause mouse is frozen

but when i go to system menu and pick help mouse is not frozen - oops - freezes there at least when seamonkey is open

Comment 3 rmknox 2011-08-30 03:55:12 UTC
i stopped seamonkey and went back to gnome help and the mouse works fine there when that is the only application running

but when seamonkey was waiting and i had gnome help in another window, mouse hung in gnome help also

unless i"m wrong this all started a few weeks ago when i got an update of the kernel delivered automagicvally and system asked if it was ok to install - to whoch i replied yes

Comment 4 rmknox 2011-08-30 20:24:36 UTC
If I p[lay solitare - when the mouse cursor freezes - if I press alt tab to get the change task icon and then alt tab to return to the game - the mouse usually unfrrzes

Comment 5 rmknox 2011-08-31 14:54:55 UTC
BIG CLUE

when i interrupt grub and return to 2.6.35.13-91.fc14.i686 problem goes away

but when i try                      2.6.35.13-92.fc14.i686 i still have it

so as a workaround i'll interrupt the boot

when i say goes away i should say - maybe there are short period of mouse freeze - but if there are they are short enough so that i'm not certain they exist

Comment 6 rmknox 2011-08-31 15:41:50 UTC
System acts as if it is waiting while messages are being written
went looking and find /var/log/messages file
am booted from 13-91.fc14 version
system works great booted from win98se disk

Aug 31 08:29:29 knox kernel: [ 3047.130360] psmouse.c: Failed to enable mouse on isa0060/serio1
Aug 31 08:29:29 knox kernel: [ 3047.822911] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:29 knox kernel: [ 3047.905475] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:29 knox kernel: [ 3047.987976] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.070479] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.152982] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.235479] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.317987] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.400486] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.482989] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.565488] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.647994] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.730491] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.812996] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:30 knox kernel: [ 3048.895496] psmouse.c: bad data from KBC - timeout
Aug 31 08:29:31 knox kernel: [ 3049.225405] psmouse.c: Failed to enable mouse on isa0060/serio1
Aug 31 08:29:34 knox kernel: [ 3052.423419] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input12
Aug 31 08:30:22 knox kernel: [ 3100.526597] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:22 knox kernel: [ 3100.609160] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:22 knox kernel: [ 3100.691661] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:22 knox kernel: [ 3100.774161] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:22 knox kernel: [ 3100.856667] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:22 knox kernel: [ 3100.939167] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.021669] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.104172] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.186672] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.269175] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.351676] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.434178] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.516680] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:23 knox kernel: [ 3101.599182] psmouse.c: bad data from KBC - timeout
Aug 31 08:30:24 knox kernel: [ 3102.360696] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input13
Aug 31 08:30:25 knox kernel: [ 3103.118711] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input14

Comment 7 rmknox 2011-09-01 04:23:39 UTC
Created attachment 520949 [details]
log

Comment 8 rmknox 2011-09-01 14:12:40 UTC
i just spent an hour using adobe to read a pdf and have seen no problem with mouse
looked in var/lob/messages and no error messages there

makes me sus[pect that the programs i frequently run - firefox and thundergird - start some malign process

i currently an im opera and have not yet seen any muse p[roblems

Comment 9 rmknox 2011-09-01 14:25:14 UTC
prior message was sent using opera - i am on opera right now
after i sent it, i looked at var/log/messages
no mouse error messages

astounding because whenever i use firefox or thunderbird there are lots of mouse error messages
and mouse errors then continue to appear in other programs

workaround dejour is to use opera and never firefox 

i will now try thunderbird without  first having started firefox

Comment 10 rmknox 2011-09-01 14:30:56 UTC
Sep  1 07:24:38 knox kernel: [37709.009913] psmouse.c: bad data from KBC - timeout

i ran thunderbird and for the first time today i have a series of the above in var/log/messages

i am now in opera and all seems well here.

i'll run other programs and see if there is a lingering infection from whatever happened in thunderbird

Comment 11 rmknox 2011-09-02 23:34:16 UTC
CLUE AND WORKAROUND

I switched mice with another fedora machine I have.
Both work now. And !! I am writing this from Firefox with no mouse trouble.

Details
unit 1 -- my machine
fedora 2.6.35.14-95.fc14.i686
gnome 2.32.0
Intel Pentium 4 cpu 3.06 ghz

old mouse was Microsoft usb plugged into mouse port adapter - did not work - now have generic chinese mouseport unit and it is ok
by the way - same microsoft mouse w/o adapter plugged into usb port did not work that way either

unit 2 -- my kids machine
fedora 2.6.35.12-88.fc14.i686
gnome 2.32.0
Intel core 2 duo cpu e4500 @2.20 ghz

old mouse was chinese mouseport generic - worked ok = new mouse is microsoft usb with mouseport adapter that did not work properly on unit 1 - works ok here

I have a 3rd fedora unit - I'll try the microsoft mouse there and let you know what happens

Comment 12 rmknox 2011-09-03 01:31:40 UTC
the microsoft mouse works ok on my 3rd fedora system

2.6.35.13-92.fc14.i686
gnome 2.32.0
mobile intel pentium III CPU M 1133mhz

unit 1 hangs with it, units 2 and 3 like it

Comment 13 Martin Stransky 2012-05-03 14:49:39 UTC
Thanks for the report. It looks like a more general problem, not the firefox one. Do you still see it? If so, reopen the bug and reassign to kernel component. Thanks.


Note You need to log in before you can comment on or make changes to this bug.