Bug 73431 - ssh-agent started by /etc/X11/prefdm can't be found by ssh-add
Summary: ssh-agent started by /etc/X11/prefdm can't be found by ssh-add
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-04 17:23 UTC by Tom Wood
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 10:47:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Wood 2002-09-04 17:23:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When starting ssh-agent with /etc/X11/prefdm modified to "exec
/usr/bin/ssh-agent `which [gkx]dm` ...", the ssh-agent isn't accessible to
ssh-add from an terminal window after logging in.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Modify /etc/X11/prefdm to "exec ssh-agent" the [gkx]dm as appropriate.
2.From any xterm-like command line client such as xterm, konsole, etc., run
"ssh-add"
3.ssh-add then fails with "Could not open a connection to your authentication
agent."
	

Actual Results:  ssh-add didn't find the ssh-agent.  ssh-agent is running as
verified by ps and a search for its socket.

Expected Results:  ssh-add should have prompted me for a password.

Additional info:

The socket that ssh-agent uses is created in /tmp/ssh-XXxxxxxx/agent.<pid> as
per the man page for ssh-agent.

Dropping to runlevel 3 allows me to run the ssh-add.

This was attempted as the root user.

Repeated attempts to get this going by bouncing back and forth between init 3
and init 5 have left orphaned socket files.  This may or may not be a security
issue.

Comment 1 Tom Wood 2002-10-18 19:19:23 UTC
This bug is now over a month old and is still NEW.  Why the delay?

Comment 2 H. Peter Anvin 2002-12-11 19:32:38 UTC
In RedHat 8.0 at least ssh-agent is automatically run by /etc/X11/xdm/Xsession.
 This might be a better way to do it then hacking prefdm (especially since it
seems to work, which means RH finally has an integrated solution for the
ssh-agent problem.)


Comment 3 Tomas Mraz 2005-02-04 10:47:11 UTC
RH 7.3 is no longer supported.


Comment 4 Tom Wood 2005-02-06 01:47:07 UTC
Smooth move, Red Hat.  Wait until 29 months after I first file this
bug to respond.


Note You need to log in before you can comment on or make changes to this bug.