Bug 73433 - apache/httpd.h HARD_SERVER_LIMIT too small
apache/httpd.h HARD_SERVER_LIMIT too small
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 13:47 EDT by Paul Thublin
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-04 06:02:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Thublin 2002-09-04 13:47:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; H010818; 
T312461; Hewlett-Packard IE5.5-SP2)

Description of problem:
The Apache config directive MaxClients is limited by a hard-compiled
constant in httpd.h called HARD_SERVER_LIMIT.  For Linux, this limit
is set to 256, which is woefully inadequate for today's systems that
may need to have as many as 2048 concurrent clients.

Please up the hard limit in your base distro to 2048.  If customers
do not want that many servers running (say because they're on an older
system), then they can manually lower the MaxClients config variable
to whatever they want, but there's nothing short of a recompile that
we can do to go higher.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Hand-edit the apache httpd.conf file to set MaxClients higher than 256.  Start 
the server.  Observe that the server reports that it is automatically resetting 
the value back to the hard-compiled limit.	

Actual Results:  The server reported that it was automatically resetting the 
limit back down to the hard-compiled limit of 256.

Expected Results:  It would be nice to see the server able to set the 
MaxClients limit as high as 2048.

Additional info:

This can be worked around by recompiling the apache httpd binary, but this is 
not an option for everyone (strict software appropriation standards, no 
development platform, etc.)
Comment 1 Paul Thublin 2002-09-04 13:49:02 EDT
I'd really like this for 7.2 and later versions of RedHat, also.

Thanks!
Comment 2 Joe Orton 2002-09-18 11:43:41 EDT
Refiling against Apache 2.0 package.
Comment 3 Janne Pikkarainen 2002-12-10 04:56:47 EST
In Apache 2.0 this limit can be changed via the httpd.conf's ServerLimit
configuration value.

For example:

ServerLimit 2048
MaxClients 2048

Working for me in Apache 2 bundled with Red Hat 8.0.
Comment 4 Joe Orton 2003-03-04 06:02:13 EST
As noted, this works in 2.0. It's hard (if not impossible) to fix for 1.3
without changing the binary module interface.

Note You need to log in before you can comment on or make changes to this bug.