Bug 734359 - auditd.service is not installed on ppc
Summary: auditd.service is not installed on ppc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audit
Version: 16
Hardware: powerpc
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 07:42 UTC by Jiri Skala
Modified: 2014-11-09 22:34 UTC (History)
2 users (show)

Fixed In Version: audit-2.1.3-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 03:31:46 UTC


Attachments (Terms of Use)

Description Jiri Skala 2011-08-30 07:42:15 UTC
Description of problem:
The unit file auditd.service is not installed on ppc due to %ifnarch check. Audit's build fails.

I'm convinced this check should be removed. Alternatively could be completed with the same check in %files section.

What's the reason of the check?

Version-Release number of selected component (if applicable):
audit-2.1.3-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Audit builds on ppc

Additional info:

Comment 1 Steve Grubb 2011-08-30 17:30:29 UTC
The %ifnarch appears to be misplaced due to a patch against the specfile going bad. Moved it down where it belongs.

Comment 2 Fedora Update System 2011-08-30 17:50:25 UTC
audit-2.1.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/audit-2.1.3-2.fc16

Comment 3 Fedora Update System 2011-08-30 20:39:25 UTC
Package audit-2.1.3-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audit-2.1.3-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/audit-2.1.3-2.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-09-07 03:31:39 UTC
audit-2.1.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.