Bug 734385 - perl-Crypt-SSLeay: stop shipping own certificate bundle
Summary: perl-Crypt-SSLeay: stop shipping own certificate bundle
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Crypt-SSLeay
Version: rawhide
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 09:44 UTC by Tomas Hoger
Modified: 2011-09-07 12:35 UTC (History)
2 users (show)

Fixed In Version: perl-Crypt-SSLeay-0.58-7.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1059992 (view as bug list)
Environment:
Last Closed: 2011-09-07 12:35:02 UTC


Attachments (Terms of Use)

Description Tomas Hoger 2011-08-30 09:44:37 UTC
Description of problem:
perl-Crypt-SSLeay ships own ca-bundle.crt file in the /usr/share/doc/perl-Crypt-SSLeay-<version>.  According to the "Last Modified" date in the file, it has not been updated since 2000.  It's docs only, but as it's getting quite venerable (lot of certs are expired, other needed today are most likely missing), it should be removed or replaced with a symlink to ca-certificate's one if it's really needed.

Comment 1 Petr Šabata 2011-08-30 11:46:30 UTC
I'd like to replace it with a symlink to /etc/pki/tls/certs/ca-bundle.crt, as you've suggested...  unless somebody has a better idea.

Comment 2 Tomas Hoger 2011-08-30 12:02:57 UTC
Do you actually expect it to be used anywhere?  I suspect it can only get used if someone copies it from /usr/share/doc, but never directly (given the changing directory name).  Hence there should be low regression risk if the file is removed completely.

Comment 3 Petr Šabata 2011-08-30 12:14:04 UTC
The file is mentioned in the documentation and could be used with the example tools (%doc eg/).  I'd rather keep it.

Comment 4 Tomas Hoger 2011-08-30 12:36:27 UTC
As far as I can see, all references to ca-bundle.crt within the package are of the form certs/ca-bundle.crt, so they can not refer to the file in the doc directory directly.

Comment 5 Petr Šabata 2011-08-30 12:59:50 UTC
Yes but that's just where we put the 'certs' directory.  It's better than nothing, imo.

Comment 6 Petr Šabata 2011-09-07 12:35:02 UTC
perl-Crypt-SSLeay-0.58-7.fc17 ca-bundle.crt now points to ca-certificates ca-bundle.crt ...


Note You need to log in before you can comment on or make changes to this bug.