Bug 734387 - "English" and "To English" isn't translatable
Summary: "English" and "To English" isn't translatable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iok
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 09:46 UTC by Akira TAGOH
Modified: 2011-10-25 03:31 UTC (History)
4 users (show)

Fixed In Version: iok-1.3.13-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-18 05:57:56 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2011-08-30 09:46:23 UTC
Description of problem:
"English" in the language list and "To English" button isn't translated and I don't see any translatable entry in po either.

Version-Release number of selected component (if applicable):
iok-1.3.12-3.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.run iok with non-English locale
2.see the language list and the "To English" key
3.
  
Actual results:
not translated nor is translatable.

Expected results:
should be translatable and translated.

Additional info:
This fix would breaks the string freeze policy, you may need to ask translators on the trans list.

Comment 1 Parag Nemade 2011-08-30 13:50:27 UTC
Its deliberately kept. Considering English language knowing people want to learn Indic languages and for them not to confuse how to switch back from the Indic language to English, its kept as English string(untranslated)

pot is edited before pushing to translation so that those strings will not get translated.

Comment 2 Akira TAGOH 2011-08-31 01:35:35 UTC
That makes no sense at all since other keys is also translated.

Aside from that, as long as you use the gettext for localization framework, it's localized against current locale. given that we are on the situation where you are concerned, usually the whole translations on the desktop should appears in any Indic languages. do we really need to worry about it in that case? most cases I've ever seen for those who use multiple languages on the desktop is to use English locale as the base locale and set LC_CTYPE for the language what they want to learn.

In addition, people who speak English only is going to learn Indic would be wrong assumption. if the above concern is really an issue, I would suggest to show both strings, locale-based translated strings and English say or use an icon.

Comment 3 Parag Nemade 2011-08-31 04:14:00 UTC
As you can see this project is already developed and no further updates to iok happened since long time. In the current code, I see no pot modification is happening as those strings are individual string values being copied as label value on that left lower corner button.

Do you want me to also have localized translated buttons for Tab, Shift, Enter, Caps, ESC ?

Comment 4 Akira TAGOH 2011-08-31 04:40:14 UTC
maybe you can see how eekboard implements.

FWIW I don't see any good reason that iok toggles masking/unmasking the language list when clicking "To English" button though. there should be still some improvements on UI, but anyway.

Comment 5 Parag Nemade 2011-08-31 05:37:01 UTC
Its one of the requirement while developing iok that once people are using any layout and want to quickly type latin letters then there should be some toggle to switch from latin to non-latin and vice-versa.

Suggestions to improve UI is always welcome.

Comment 6 Parag Nemade 2011-08-31 05:45:19 UTC
I think you should test just iok command and not its complete UI.
LANG=hi_IN.UTF-8 iok

When you run iok in its default mode, you need some way to toggle as people who don't want to see all the keymaps installed in language list.

Comment 7 Akira TAGOH 2011-08-31 06:09:16 UTC
I did. otherwise how come I know how iok behaves on them? :)

As I suggested some the above, there might be a lot of things can be learned from eekboard perhaps.

Anyway you should separately think the convenience for development/testing and for regular use on the UI implementation. that would has different goals and direction to satisfy the requirements. as you yourself said in the above comment, people usually don't want to see everything in the language list. to be honest, current UI on iok may be comfortable for developer or testers, but not for the end users.

Comment 8 Parag Nemade 2011-08-31 07:06:05 UTC
eekboard-inscript need to manually specify the complete keymap file name without ".mim"

eekboard behaves similar for toggle from any inscript map to English and vice-versa.

and some other issue with eekboard for Indic characters.

Comment 9 Parag Nemade 2011-08-31 07:19:37 UTC
How can displaying by default all the language list for a person who just want to use Hindi desktop be user-friendly?

One of the goal for iok development was to have a simple UI and not to show much more added functionalities by default for non-English locale.

Comment 10 Akira TAGOH 2011-08-31 09:32:30 UTC
Well, you are missing the point though, I should file a separate bug for UI improvements. mixing up this translation issue and UI may makes it complicated.

For "To English" button and possibly other translated keys already, I still have some objection to keep non-translated string there though, that would rather be better having the icon instead of the string perhaps, because assuming one who wants to use iok can read English would be wrong.
there should be a chance to learn Indic for those who don't know English anyway.

Comment 11 Parag Nemade 2011-08-31 10:34:14 UTC
Ankit,
    Would you recommend translations for "English" "to English" key labels and other key labels say Tab, Enter. Shift, Caps, Backspace, Space ?

Tagoh is suggesting to have those button labels translated.

Comment 12 Ankit Patel 2011-09-02 06:45:55 UTC
(In reply to comment #11)
> Ankit,
>     Would you recommend translations for "English" "to English" key labels and
> other key labels say Tab, Enter. Shift, Caps, Backspace, Space ?
> 
> Tagoh is suggesting to have those button labels translated.

In my opinion, we should let this to be decided by each individual translator for their language's translation. So, I would say, let these messages marked as "Translatable" and provide enough "Localization (or translation) comments" in order to provide a context to the translator. This will help translator to understand where these messages are going to appear and they can make a decision accordingly.

Having this approach followed, we can have variance for each individual language for translations, e.g.
1. language X translating all these messages
2. language Y transliterating all these messages
3. language Z translating and putting English within brackets
4. language A keeping these messages in English as it is

And I think having such results should be fine, as translators know their language and customers better than us.

Thanks!
Ankit

Comment 13 Parag Nemade 2011-09-05 10:16:23 UTC
Thanks Ankit and Tagoh for your input. I will add those 2 strings and update the pot file in svn. Soon, I will release new iok and when I will build it in Fedora, I will close this bug.

Comment 14 Parag Nemade 2011-10-18 05:57:56 UTC
Built in rawhide iok-1.3.13-1.fc17. Will build for F16 soon.

Comment 15 Fedora Update System 2011-10-18 06:20:38 UTC
iok-1.3.13-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/iok-1.3.13-1.fc16

Comment 16 Fedora Update System 2011-10-25 03:31:15 UTC
iok-1.3.13-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.