Bug 734471 - Error while launching instance for ec2 in conductor UI ( The instance gets launched)
Summary: Error while launching instance for ec2 in conductor UI ( The instance gets la...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Tomas Sedovic
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 14:08 UTC by Shveta
Modified: 2012-05-15 21:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 21:52:56 UTC


Attachments (Terms of Use)
Image_error (211.85 KB, image/png)
2011-08-30 14:08 UTC, Shveta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 22:31:59 UTC

Description Shveta 2011-08-30 14:08:51 UTC
Created attachment 520616 [details]
Image_error

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install aeolus 
2. Aeolus configure shows deltacloud error (https://bugzilla.redhat.com/show_bug.cgi?id=733728)
3. started deltacloud for east manually 
/etc/init.d/deltacloud-ec2-us-east-1 status
deltacloud-ec2-us-east-1.service - SYSV: deltacloud-core is primary server process for the Deltacloud Core component.
	  Loaded: loaded (/etc/rc.d/init.d/deltacloud-ec2-us-east-1)
	  Active: active (running) since Tue, 30 Aug 2011 09:09:16 -0400; 11s ago
	 Process: 6555 ExecStart=/etc/rc.d/init.d/deltacloud-ec2-us-east-1 start (code=exited, status=0/SUCCESS)
	Main PID: 6558 (deltacloudd)
	  CGroup: name=systemd:/system/deltacloud-ec2-us-east-1.service
		  └ 6558 /usr/bin/ruby /usr/bin/deltacloudd -i ec2 -e prod...

4. added provider and account
5. Build and Pushed image (No error )
6. Launched deployment .. 

Instance state shows Error however the instance is launched in amazon account.
The key can also be downloaded.
  
Actual results:


Expected results:


Additional info:

Deltacloud::BackendError - InvalidInstanceID.NotFound: The instance ID 'i-e13f2780' does not exist
REQUEST=ec2.us-east-1.amazonaws.com:443/?AWSAccessKeyId=AKIAI2KPFDYVZKSRTJMQ&Action=CreateTags&ResourceId.1=i-e13f2780&SignatureMethod=HmacSHA256&SignatureVersion=2&Tag.1.Key=name&Tag.1.Value=Condor_localhost_intel-d3c4702-01.rhts.eng.bos.redhat.com%231.0%231314712662&Timestamp=2011-08-30T13%3A57%3A51.000Z&Version=2010-08-31&Signature=ezz2MGLbLHo0%2Fd6KpYrJd%2BDTtGyN38kJJyrWkqv5iYQ%3D
REQUEST ID=044452a2-e527-442f-8d22-74b1adb8d096 :
 ././lib/deltacloud/base_driver/base_driver.rb:247:in `safely'
 ././lib/deltacloud/base_driver/base_driver.rb:245:in `each'
 ././lib/deltacloud/base_driver/base_driver.rb:245:in `safely'
 ././lib/deltacloud/drivers/ec2/ec2_driver.rb:208:in `create_instance'
 ././server.rb:400
 ././lib/sinatra/rabbit.rb:104:in `instance_eval'
 ././lib/sinatra/rabbit.rb:104:in `POST /api/instances'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1151:in `call'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1151:in `compile!'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:724:in `instance_eval'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:724:in `route_eval'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:708:in `route!'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:758:in `process_route'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:755:in `catch'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:755:in `process_route'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:707:in `route!'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:706:in `each'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:706:in `route!'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:843:in `dispatch!'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:644:in `call!'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `instance_eval'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `invoke'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `catch'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `invoke'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `catch'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `invoke'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:644:in `call!'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:629:in `call'
 ././lib/sinatra/rack_driver_select.rb:45:in `call'
 ././lib/sinatra/rack_matrix_params.rb:80:in `call'
 ././lib/sinatra/rack_runtime.rb:36:in `call'
 ././lib/sinatra/rack_etag.rb:42:in `call'
 /usr/lib/ruby/gems/1.8/gems/rack-accept-0.4.3/lib/rack/accept/context.rb:22:in `call'
 /usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/head.rb:9:in `call'
 /usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/commonlogger.rb:18:in `call'
 /usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/methodoverride.rb:24:in `call'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1272:in `call'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1303:in `synchronize'
 /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1272:in `call'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/stats.rb:24:in `call'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/stats.rb:33:in `log'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/stats.rb:24:in `call'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:84:in `pre_process'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:82:in `catch'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:82:in `pre_process'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1060:in `call'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1060:in `spawn_threadpool'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057:in `initialize'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057:in `new'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057:in `spawn_threadpool'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1049:in `defer'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:54:in `process'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:42:in `receive_data'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run_machine'
 /usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/backends/base.rb:61:in `start'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/server.rb:159:in `start'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/controllers/controller.rb:86:in `start'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:185:in `send'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:185:in `run_command'
 /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
 /usr/share/deltacloud-core/bin/deltacloudd:124
 /usr/bin/deltacloudd:5:in `load'
 /usr/bin/deltacloudd:5

Comment 1 Shveta 2011-08-30 15:12:27 UTC
Template used was 
============================================


<template>
  <name>f14audrey</name>
  <os>
    <name>Fedora</name>
    <version>14</version>
    <arch>x86_64</arch>
    <install type='iso'>
      <iso>http://download.devel.redhat.com/released/F-14/GOLD/Fedora/x86_64/iso/Fedora-14-x86_64-DVD.iso</iso>
    </install>
  </os>
  <repositories>
    <repository name='audreyrepo'>
      <url>http://repos.fedorapeople.org/repos/aeolus/audrey/fedora-14/x86_64/</url>
      <signed>False</signed>
    </repository>
  </repositories>
  <packages>
    <package name='aeolus-audrey_startup'/>
    <package name='aeolus-audrey_puppet'/>
    <package name='aeolus-rhevm_config_server'/>
    <package name='puppet'/>
    <package name='python-httplib2'/>
  </packages>
  <description>Fedora 14 With Audrey Packages</description>
</template>

Comment 2 Shveta 2011-08-30 15:15:08 UTC
Instance launched with normal template gets launched.

<template>
  <name>RHEL_postgres</name>
  <os>
    <name>RHEL-6</name>
    <version>1</version>
    <arch>x86_64</arch>
    <install type="url">

<url>http://download.eng.pnq.redhat.com/pub/rhel/released/RHEL-6/6.1/Server/x86_64/os/</url>
    </install>
  </os>
  <description>RHEL61 x86_64 with postgres</description>
  <packages>
    <package name='postgresql-server'/>
  </packages>
</template>

Comment 3 wes hayutin 2011-08-30 19:18:49 UTC
ya.. interesting.. I've seen something similar..

Comment 4 wes hayutin 2011-09-28 16:38:53 UTC
making sure all the bugs are at the right version for future queries

Comment 6 wes hayutin 2012-01-12 16:53:20 UTC
adding to sprint tracker

Comment 7 Shveta 2012-01-25 06:11:02 UTC
Not seeing this issue anymore

Verified in 
rpm -qa|grep aeolus
aeolus-conductor-0.8.0-11.el6.noarch
aeolus-conductor-doc-0.8.0-11.el6.noarch
rubygem-aeolus-image-0.3.0-3.el6.noarch
rubygem-aeolus-cli-0.3.0-5.el6.noarch
aeolus-all-0.8.0-11.el6.noarch
aeolus-configure-2.5.0-7.el6.noarch
aeolus-conductor-daemons-0.8.0-11.el6.noarch

Comment 9 errata-xmlrpc 2012-05-15 21:52:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html


Note You need to log in before you can comment on or make changes to this bug.