Bug 734474 - better error message for missing enviroment on katello
Summary: better error message for missing enviroment on katello
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: Entitlement Bugs
URL:
Whiteboard:
Depends On:
Blocks: 738066 756082
TreeView+ depends on / blocked
 
Reported: 2011-08-30 14:19 UTC by Shannon Hughes
Modified: 2012-06-20 12:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 12:56:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0804 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2012-06-19 19:51:31 UTC

Description Shannon Hughes 2011-08-30 14:19:01 UTC
Description of problem:

when registering a system to katello and there is no enviroment defined in katello there is no indication from subscription manager that there is a problem. no output is given at the cli. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 7 John Sefler 2012-03-16 18:36:29 UTC
Verifying version....

candlepin-0.5.26-1.el6.noarch
katello-0.1.304-1.el6.noarch


[root@ibm-ls22-04 ~]# rpm -q subscription-manager
subscription-manager-0.99.10-1.el6.x86_64
[root@ibm-ls22-04 ~]# subscription-manager environments --username admin --org bbbbb
Password: 
+-------------------------------------------+
          Environments
+-------------------------------------------+
Name:                 	Library                  
Description:          	None                     

[root@ibm-ls22-04 ~]# subscription-manager register --username admin --org bbbbb
Password: 
Organization bbbbb has 'Library' environment only. Please create an environment for system registration.
[root@ibm-ls22-04 ~]# subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.


^^^ VERIFIED, The user is now informed during registration that there is no environment defined for his org and his registration is aborted.


moving to VERIFIED

Comment 8 John Sefler 2012-03-16 19:46:29 UTC
Note that the "Library" environment is really a special environment and will not act as the default environment even though it appears to be available when making a call to subscription-manager environments to list the available environments.

My suggestion is for the Katello dev team to rename this special environment to "Library (reserved)" to help indicated that it is special; just an idea.

Comment 10 errata-xmlrpc 2012-06-20 12:56:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html


Note You need to log in before you can comment on or make changes to this bug.