Bug 734483 - host name resolution fail
Summary: host name resolution fail
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnstracer
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthieu Saulnier
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 14:39 UTC by melanphos
Modified: 2012-01-11 13:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-11 13:59:27 UTC


Attachments (Terms of Use)

Description melanphos 2011-08-30 14:39:25 UTC
Description of problem:

very often, DNS resolution fail.


Version-Release number of selected component (if applicable):
Fedora 15 up to date


How reproducible:
Every time for me, but not for every one i guess.


Steps to Reproduce:
1. try 
$ wget http://mozzila.org
--2011-08-30 16:25:35--  http://mozzila.org/
Resolving mozzila.org... failed: Name or service not known.
wget: unable to resolve host address `mozzila.org'

2. first try fail, then a second :

$ wget http://mozzila.org
--2011-08-30 16:25:37--  http://mozzila.org/
Resolving mozzila.org... 209.85.51.152
Connecting to mozzila.org|209.85.51.152|:80... connected.


The same for every sites, and every soft (wget, yum, firefox…)
  

Additional info:
Only fedora 15 is affected, its a fresh install. I never had this problem before with any distro

Here the error message of curl, maybe interesting :

$ curl www.centos.org
curl: (6) Could not resolve host: www.mozzila.org; Cannot allocate memory
(as usual, second try worked)

Notice also that if i do 
$ wget host.com
(fail)
$ curl host.com
(same host, fail too)
$ wget host.com
(succeed !)

Comment 1 melanphos 2011-08-31 01:36:29 UTC
I just seen that nslookup work perfectly. I realy don't understand what's happen.

Comment 2 melanphos 2011-09-01 00:31:37 UTC
I have done a new install on a 32bits computers, the problem wasn't here before I updated it.
So this bug as been introduced after the release of fedora 15…

Comment 3 melanphos 2011-09-02 16:06:45 UTC
I used a Livebox (by Orange) as DNS. If i use any other DNS server, no problem anymore.

Comment 4 melanphos 2011-11-11 12:26:12 UTC
With fedora 16 : same problem, same solution :)

Comment 5 Fedora Admin XMLRPC Client 2012-01-11 12:01:39 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Matthieu Saulnier 2012-01-11 13:59:27 UTC
Hello,
as I see you have solved the problem, I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.