Bug 734503 - Download Key shows error :The requested URL /instances/2/key was not found on this server.
Summary: Download Key shows error :The requested URL /instances/2/key was not found on...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Jan Provaznik
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 15:43 UTC by Shveta
Modified: 2012-05-15 21:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 21:53:00 UTC


Attachments (Terms of Use)
key_err (20.13 KB, image/png)
2011-08-30 15:43 UTC, Shveta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 22:31:59 UTC

Description Shveta 2011-08-30 15:43:13 UTC
Created attachment 520630 [details]
key_err

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Launched an instance for ec2 
2. Clicking on download link shows error 
3. Not Found

The requested URL /instances/2/key was not found on this server.
Apache/2.2.19 (Fedora) Server at intel-d3c4702-01.rhts.eng.bos.redhat.com Port 443
  
Actual results:


Expected results:


Additional info:
rpm -qa|grep aeolus
aeolus-configure-2.0.2-1.20110823163326gitc322d7f.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110824113236git15b6922.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110829181358gitfb3ebb2.fc15.noarch
aeolus-conductor-0.4.0-0.20110829181358gitfb3ebb2.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110829181358gitfb3ebb2.fc15.noarch
aeolus-all-0.4.0-0.20110829181358gitfb3ebb2.fc15.noarch

Not Found

The requested URL /instances/2/key was not found on this server.
Apache/2.2.19 (Fedora) Server at intel-d3c4702-01.rhts.eng.bos.redhat.com Port 443

Comment 1 Joe Vlcek 2011-09-19 17:46:51 UTC
The URL path seems to be missing: "/conductor" 

The key is correctly downloaded if "/conductor" is inserted in front of "/instances/2/key" in the URL:

e.g.:

https://<host>/conductor/instances/1/key

Until this bug is resolved this can be a workaround.

Hats off to Daniel Radez <dradez@redhat.com> for pointing this out.

Comment 2 Jan Provaznik 2011-09-24 06:16:50 UTC
Fixed in commit cb114225d3ca27e856299016b753fc7c6a28c09e of conductor master branch

Comment 3 wes hayutin 2011-09-28 16:37:07 UTC
making sure all the bugs are at the right version for future queries

Comment 5 Joe Vlcek 2011-10-06 13:12:57 UTC
The above error is no longer observed.

verification details:

%  rpm -qa | egrep 'aeolus|imagefactory'
aeolus-configure-2.0.2-4.20110930103205gitaf78594.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20111004192348git2cf5ee6.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20111004192348git2cf5ee6.fc15.noarch
aeolus-all-0.4.0-0.20111004192348git2cf5ee6.fc15.noarch
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.fc15.noarch
rubygem-aeolus-cli-0.1.0-3.20111003133323git9451323.fc15.noarch
imagefactory-0.6.2-1.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20111003132331gitb88f6ee.fc15.noarch
aeolus-conductor-0.4.0-0.20111004192348git2cf5ee6.fc15.noarch

Comment 7 errata-xmlrpc 2012-05-15 21:53:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html


Note You need to log in before you can comment on or make changes to this bug.