Bug 734506 - [abrt] kernel: WARNING: at lib/dma-debug.c:875 check_for_stack+0x95/0xd3(): TAINTED ---------W
[abrt] kernel: WARNING: at lib/dma-debug.c:875 check_for_stack+0x95/0xd3(): T...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mauro Carvalho Chehab
Fedora Extras Quality Assurance
abrt_hash:95b49b322e543cffda037cb5f07...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-30 11:55 EDT by Mikko Tiihonen
Modified: 2013-07-04 18:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-28 16:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikko Tiihonen 2011-08-30 11:55:23 EDT
abrt version: 2.0.5
cmdline:        ro root=UUID=10033589-14c8-48f0-8d13-e2b4bf44fce6 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=fi selinux=0 pcie_aspm=force
comment:        I plugged in my usb dvb device
kernel:         undefined
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
reason:         WARNING: at lib/dma-debug.c:875 check_for_stack+0x95/0xd3()
time:           Tue Aug 30 18:53:37 2011

backtrace:
:WARNING: at lib/dma-debug.c:875 check_for_stack+0x95/0xd3()
:Hardware name: 42844DG
:ehci_hcd 0000:00:1a.0: DMA-API: device driver maps memory fromstack [addr=ffff88040f91bbe0]
:Modules linked in: ir_sony_decoder(+) ir_jvc_decoder dvb_usb_ttusb2(+) ir_rc6_decoder dvb_usb ir_rc5_decoder ir_nec_decoder dvb_core rc_core arc4 uvcvideo videodev media cdc_wdm v4l2_compat_ioctl32 cdc_acm cdc_ncm usbnet mii btusb bluetooth snd_hda_codec_hdmi microcode(+) joydev snd_hda_codec_conexant iwlagn snd_hda_intel snd_hda_codec i2c_i801 snd_hwdep mac80211 snd_seq iTCO_wdt snd_seq_device iTCO_vendor_support snd_pcm cfg80211 snd_timer snd_page_alloc e1000e thinkpad_acpi rfkill snd soundcore virtio_net kvm_intel kvm uinput btrfs
:IR Sony protocol handler initialized
: zlib_deflate libcrc32c firewire_ohci sdhci_pci sdhci firewire_core crc_itu_t mmc_core nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video
:Pid: 850, comm: modprobe Not tainted 3.1.0-0.rc4.git0.0.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8105c534>] warn_slowpath_common+0x83/0x9b
: [<ffffffff8105c5ef>] warn_slowpath_fmt+0x46/0x48
: [<ffffffff812636f2>] check_for_stack+0x95/0xd3
: [<ffffffff8126391b>] debug_dma_map_page+0xb6/0xdf
: [<ffffffff81370a40>] dma_map_single_attrs.constprop.7+0xa9/0xbc
: [<ffffffff81370ca9>] usb_hcd_map_urb_for_dma+0x256/0x2e1
: [<ffffffff8108f442>] ? mark_held_locks+0x6d/0x95
: [<ffffffff81371342>] usb_hcd_submit_urb+0x60e/0x6eb
: [<ffffffff8108c295>] ? lockdep_init_map+0x99/0x10e
: [<ffffffff81372155>] usb_submit_urb+0x301/0x313
: [<ffffffff8107ab17>] ? __init_waitqueue_head+0x3a/0x4b
: [<ffffffff81372e13>] usb_start_wait_urb+0x70/0x174
: [<ffffffff81372287>] ? usb_alloc_urb+0x1b/0x43
: [<ffffffff81373049>] usb_bulk_msg+0x132/0x148
: [<ffffffffa04f3a26>] dvb_usb_generic_rw+0xbe/0x17f [dvb_usb]
: [<ffffffffa04f341d>] ? kzalloc.constprop.2+0x13/0x15 [dvb_usb]
: [<ffffffffa04fe0d9>] ttusb2_msg+0xad/0x120 [dvb_usb_ttusb2]
: [<ffffffffa04fe2ee>] ttusb2_power_ctrl+0x2b/0x4e [dvb_usb_ttusb2]
: [<ffffffffa04f345e>] dvb_usb_device_power_ctrl+0x3f/0x41 [dvb_usb]
: [<ffffffffa04f36df>] dvb_usb_device_init+0x27f/0x4b4 [dvb_usb]
: [<ffffffffa04fe69e>] ttusb2_probe+0x73/0x84 [dvb_usb_ttusb2]
: [<ffffffff81375f2a>] usb_probe_interface+0x150/0x1bd
: [<ffffffff81317137>] driver_probe_device+0x131/0x213
: [<ffffffff81317277>] __driver_attach+0x5e/0x82
: [<ffffffff81317219>] ? driver_probe_device+0x213/0x213
: [<ffffffff81316178>] bus_for_each_dev+0x59/0x8f
: [<ffffffff81316d0b>] driver_attach+0x1e/0x20
: [<ffffffff81316923>] bus_add_driver+0xd4/0x22a
: [<ffffffff8131773a>] driver_register+0x98/0x105
: [<ffffffff81375057>] usb_register_driver+0xb8/0x17c
: [<ffffffffa02d9000>] ? 0xffffffffa02d8fff
: [<ffffffffa02d9021>] ttusb2_module_init+0x21/0x1000 [dvb_usb_ttusb2]
: [<ffffffff81002099>] do_one_initcall+0x7f/0x13a
: [<ffffffffa02d9000>] ? 0xffffffffa02d8fff
: [<ffffffff8109a6fc>] sys_init_module+0x114/0x267
: [<ffffffff8150b742>] system_call_fastpath+0x16/0x1b
Comment 1 Josh Boyer 2011-11-02 15:24:20 EDT
This is because the ttusb2 driver uses stack variables with the DMA API, which is not allowed.  I'll look at if I can fix the driver up.
Comment 3 Dave Jones 2012-01-30 14:39:41 EST
Mauro, can you push that along upstream please if it looks ok ?
Comment 4 Josh Boyer 2012-02-28 16:03:59 EST
This was included in the 3.3-rc1 kernel.  Given it's just a warning and we only enable the debug options by default on rawhide, I'm going to close this bug out for now.  F16 will pick up the fix when it rebases to 3.3 anyway.

Note You need to log in before you can comment on or make changes to this bug.