Bug 734517 - Content > Promotions: direct download link for a package points to localhost.
Summary: Content > Promotions: direct download link for a package points to localhost.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-30 16:41 UTC by Corey Welton
Modified: 2013-08-16 18:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:54:33 UTC


Attachments (Terms of Use)
screenshot (22.16 KB, image/png)
2011-08-30 16:46 UTC, Corey Welton
no flags Details

Description Corey Welton 2011-08-30 16:41:52 UTC
Description of problem:
When user tries to click the link listed in the package info pane, it fails; upon closer inspection, the URL is pointing to localhost, not the katello server.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Sync a content channel.
2. Content > Promotions > Product > Packages > $package name
3. View resulting package info pane on right.
4. Observe URL listed for the Download link
  
Actual results:
localhost link

Expected results:
proper link

Additional info:

Comment 1 Corey Welton 2011-08-30 16:46:01 UTC
Created attachment 520646 [details]
screenshot

Comment 2 Eric Helms 2011-09-09 15:11:44 UTC
The URL link in question is a value coming from Pulp.  Pulp appears to derive the hostname from the pulp.conf file specifically:

[server]
server_name: localhost

Comment 3 Corey Welton 2011-10-25 04:05:35 UTC
This seems like maybe something the backend team should fix in the puppet script, then - put the proper value in pulp.conf. 

adding inecas to the CC: for his thoughts

Comment 4 Ivan Necas 2011-10-25 09:39:46 UTC
Pulp puppet manifest fixed to correctly set up the hostname: commit 5cda0fa0488b4871533d2e6e56a770a2e976c58e

Note 1: it's required to synchronize the repo again for the change in the pulp.conf to take effect

Note 2: the download url still is not correct, waiting for Pulp to fix the bug
https://bugzilla.redhat.com/show_bug.cgi?id=745751

Comment 5 Corey Welton 2012-01-19 15:56:36 UTC
Verified.

Comment 8 Mike McCune 2013-08-16 18:02:30 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.