Bug 734522 - matahari-qmf-service-cli needs to require resource instance name
Summary: matahari-qmf-service-cli needs to require resource instance name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Russell Bryant
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-30 16:56 UTC by Dave Johnson
Modified: 2011-12-06 11:42 UTC (History)
2 users (show)

Fixed In Version: matahari-0.4.4-1.el6
Doc Type: Bug Fix
Doc Text:
No description required.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:42:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-30 16:56:14 UTC
Description of problem:
================================
Running the following starts a reource without a resource name.  Once started there is no way to cancel the resource without restarting the service agent. 

[root@agent sbin]#  ./matahari-qmf-service-cli -A Dummy -J heartbeat -S ocf -T Resources -a start -i 5 -t 10 -H ibm-x3650-01.ovirt.rhts.eng.bos.redhat.com

    matahariproject.org:service:22da4ef8-6143-4c26-a0c9-565e474a8b53
    Call options: {action:start, agent:Dummy, interval:5000, parameters:{},    
      provider:heartbeat, standard:ocf, timeout:10000}
    Call returned: {rc:2}

errors in debug:
    operation_finished: _start_5000:15849 - exited with rc=2
    operation_finished: _start_5000:15849 [ Dummy[15849]: ERROR: Need to 
       tell us our resource instance name. ]

Version-Release number of selected component (if applicable):
=================================================================
v0.4.2-9

How reproducible:
================================
100%

Steps to Reproduce:
============================
1.  install/start matahari broker
2.  yum -y install matahari-service matahari-consoles resource-agents
3.  start service agent on cmd line with -vvv
4.  in another terminal, run command:
      matahari-qmf-service-cli -A Dummy -J heartbeat -S ocf -T Resources
         -a start -i 5 -t 10 
  
Actual results:
=================
resource starts without name, recurring actions show error, no way to stop (cancel)

Expected results:
=================
command should force name to be specified

Comment 4 Dave Johnson 2011-09-12 14:32:42 UTC
Its better, be nice if we gave a little more info as to what is invalid about it, like 'missing name argument' but...

[root@dell-pem600-01 init.d]# /usr/sbin/matahari-qmf-service-cli -b 127.0.0.1 -A Dummy -J heartbeat -S ocf -T Resources -a start -i 5000 -t 10000
matahariproject.org:service:19d01dbd-dad5-49fa-856c-cff8ed0e36ac
Call options: {action:start, agent:Dummy, interval:5000, parameters:{}, provider:heartbeat, standard:ocf, timeout:10000}
Call failed: 9
Error data: {error_text:Invalid Arguments}
2011-09-12 10:29:56 warning Connection [127.0.0.1:51885-127.0.0.1:49000] closed
[root@dell-pem600-01 init.d]#

Comment 5 Russell Bryant 2011-11-16 22:04:25 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required.

Comment 6 errata-xmlrpc 2011-12-06 11:42:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.