Bug 734526 - Promotion failure when trying to simultaneously trying to promote 2 changesets should be less ambiguous
Summary: Promotion failure when trying to simultaneously trying to promote 2 changeset...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-30 17:08 UTC by Corey Welton
Modified: 2019-09-26 13:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:54:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Corey Welton 2011-08-30 17:08:40 UTC
Description of problem:
"Failed to promote: Cannot promote a changeset while another is being promoted."  This message doesn't tell the user which one failed and which is currently in process.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Configure multiple products and multiple associate change sets.
2.  Attempt to promote both (near) simultaneously
3.  Wait for failure message
  
Actual results:
Failed to promote: Cannot promote a changeset while another is being promoted.

Expected results:
Something more like
Failed to promote (My Failed Changeset): Cannot promote a changeset while another (My Changeset In Process) is being promoted.

Additional info:

Comment 1 Justin Sherrill 2011-09-19 16:58:22 UTC
should be fixed here:  

5bf345b792923605f6174792c027191cc7effc3d



Also fixed a few other issues i noticed with that page (changeset would not show it is being promoted if you refreshed the page).

Comment 2 Corey Welton 2011-09-23 18:41:05 UTC
QA verified.

Comment 5 Mike McCune 2013-08-16 18:14:14 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.