Bug 734534 - rpmbuild --sign give no error when rpm-sign is not available
Summary: rpmbuild --sign give no error when rpm-sign is not available
Keywords:
Status: CLOSED DUPLICATE of bug 697435
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 15
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 17:28 UTC by Jean-Francois Saucier
Modified: 2011-08-30 17:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-30 17:41:17 UTC


Attachments (Terms of Use)

Description Jean-Francois Saucier 2011-08-30 17:28:45 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0

When using the rpmbuild --sign command for building and signing RPM, rpmbuild give no error if rpm-sign is not available. It build the SRPM as expected but do not sign it. Installing rpm-sign fix the problem.

Reproducible: Always

Steps to Reproduce:
1.Make sure rpm-sign is not installed.
2.Run a build (ex: rpmbuid -ba --sign your_package.srpm.
3.
Actual Results:  
See that rpmbuild finish the build but did not ask for passphrase or complain that rpm-sign is not present.

Expected Results:  
rpmbuild should notice the user that it cannot sign the package due to missing rpm-sign.

Comment 1 Michael Schwendt 2011-08-30 17:41:17 UTC

*** This bug has been marked as a duplicate of bug 697435 ***


Note You need to log in before you can comment on or make changes to this bug.