Bug 734536 - timeout/interval inconsistency with matahari-qmf-service-cli
Summary: timeout/interval inconsistency with matahari-qmf-service-cli
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Russell Bryant
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-30 17:38 UTC by Dave Johnson
Modified: 2011-12-06 11:42 UTC (History)
2 users (show)

Fixed In Version: matahari-0.4.4-1.el6
Doc Type: Bug Fix
Doc Text:
No description required.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:42:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-30 17:38:14 UTC
Description of problem:
===============================
When invoking resources with qmf-tool, the timeout and interval values are specified with milli-second values but the matahari-qmf-service-cli assumes values are in seconds.  That could cause some confusion and unexpected behavior when someone thinks 5000 is 5 seconds and becomes 5000 seconds. 


Version-Release number of selected component (if applicable):
==============================================================
v0.4.2-9

How reproducible:
===============================
100%

Steps to Reproduce:
===============================
1.  run matahari-qmf-service-cli from the command line with 5 second interval
2.  run invoke from qmf-tool and see it uses milliseconds for interval and timeout

Comment 5 Dave Johnson 2011-09-12 14:27:55 UTC
good 2 go in 0.4.2-2

Comment 6 Russell Bryant 2011-11-16 22:05:04 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required.

Comment 7 errata-xmlrpc 2011-12-06 11:42:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.