Bug 734568 - postdrop causing avc failure
Summary: postdrop causing avc failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 18:52 UTC by Daniel Yeisley
Modified: 2011-12-06 10:18 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.7.19-109.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:18:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1511 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2011-12-06 00:39:17 UTC

Description Daniel Yeisley 2011-08-30 18:52:09 UTC
Description of problem:
I'm seeing beaker report an avc failure during my ISV Oracle-oast testing.  I didn't see this during my RHEL 6.1 testing.  

Version-Release number of selected component (if applicable):
RHEL6.2-20110823.1

How reproducible:
It happens with all of the 6.2 builds that I've tried.  

Steps to Reproduce:
1. Run ISV Oracle-Oast test (either 10g or 11g)
2. Wait for beaker to report the failure.
3.
  
Actual results:
Following messages were found in dmesg:
type=1400 audit(1314297049.419:363336): avc:  denied  { getattr } for  pid=12562 comm="postdrop" path="pipe:[75274]" dev=pipefs ino=75274 scontext=system_u:system_r:postfix_postdrop_t:s0-s0:c0.c1023 tcontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tclass=fifo_file

Expected results:


Additional info:
Beaker job with the reported failure: https://beaker.engineering.redhat.com/jobs/124267

Comment 2 Daniel Walsh 2011-08-30 19:31:58 UTC
Is abrt sending out email via postfix?

Comment 3 Daniel Walsh 2011-08-30 19:36:15 UTC
optional_policy(`
	abrt_rw_fifo_file(mta_user_agent)
')

Miroslav I think we need.

Comment 4 Miroslav Grepl 2011-08-31 12:24:51 UTC
Looks so.

Comment 5 Milos Malik 2011-08-31 12:27:12 UTC
Unintentionally reproduced by /CoreOS/selinux-policy/Regression/bz271561-corosync-and-similar
----
time->Wed Aug 31 08:18:58 2011
type=SYSCALL msg=audit(1314793138.223:54867): arch=c000003e syscall=5 success=no exit=-13 a0=2 a1=7fffcbb86320 a2=7fffcbb86320 a3=7fffcbb86050 items=0 ppid=29338 pid=29341 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=90 sgid=90 fsgid=90 tty=(none) ses=807 comm="postdrop" exe="/usr/sbin/postdrop" subj=system_u:system_r:postfix_postdrop_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1314793138.223:54867): avc:  denied  { getattr } for  pid=29341 comm="postdrop" path="pipe:[622070]" dev=pipefs ino=622070 scontext=system_u:system_r:postfix_postdrop_t:s0-s0:c0.c1023 tcontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tclass=fifo_file
----

Comment 6 Miroslav Grepl 2011-08-31 19:53:10 UTC
Fixed in selinux-policy-3.7.19-109.el6

Comment 9 Daniel Yeisley 2011-09-12 13:50:13 UTC
moving to verified; The original issue doesn't appear in RHEL6.2-20110907.1.

Comment 10 errata-xmlrpc 2011-12-06 10:18:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1511.html


Note You need to log in before you can comment on or make changes to this bug.