Bug 73460 - gcc warning on sstream
gcc warning on sstream
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: gcc (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 18:22 EDT by William Cohen
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: gcc-c++-3.2.3-24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-21 16:24:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The sstream.diff seems like a bandaid fix to the problem (358 bytes, patch)
2002-09-04 18:24 EDT, William Cohen
no flags Details | Diff

  None (edit)
Description William Cohen 2002-09-04 18:22:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
gcc gives a warning message about unsigned and signed compare on ia64 derry. I
originally thought this was same as bugzilla 57650, but I took a look at the
/usr/include/g++-3/sstream it it is identical to the one on an ia32 machine
which doesn't give the error message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile the attached code with

 c++  -W -Wall -Wunused -Wmissing-prototypes -pipe -g -O2 -DCONST_POPT    -c -o
example.o example.cpp -save-temps

2.
3.
	

Actual Results:  c++: Warning: -pipe ignored since -save-temps specified
In file included from example.cpp:16:
/usr/include/g++-3/sstream: In method `streampos stringbuf::seekoff 
(long int, ios::seek_dir, int)':
/usr/include/g++-3/sstream:271: warning: comparison between signed and unsigned
integer expressions


Expected Results:  no warning

Additional info:

example.cpp ---------------------


#include <unistd.h>
#include <sys/wait.h>

#include <cerrno>
#include <sstream>
#include <iostream>

int main()
{
  return 0;
}
Comment 1 William Cohen 2002-09-04 18:24:32 EDT
Created attachment 74924 [details]
The sstream.diff seems like a bandaid fix to the problem

Note You need to log in before you can comment on or make changes to this bug.