Bug 734605 - some header files in anjuta-devel contain deprecated GTK symbols
Summary: some header files in anjuta-devel contain deprecated GTK symbols
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anjuta
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cosimo Cecchi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 21:42 UTC by Christian Krause
Modified: 2013-04-30 22:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-28 15:08:23 UTC


Attachments (Terms of Use)

Description Christian Krause 2011-08-30 21:42:20 UTC
Description of problem:
Some header files in anjuta-devel contain deprecated GTK symbols, at least:
/usr/include/libanjuta-3.0/libanjuta/anjuta-status.h contains
'GtkHBox' and 'GtkHBoxClass'.

Version-Release number of selected component (if applicable):
anjuta-devel-3.1.4-1.fc16.x86_64
gtk3-devel-3.1.12-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
- compile a project which uses the e.g. anjuta-status.h with disabled deprecated symbols (-DGTK_DISABLE_DEPRECATED)
  
Actual results:
compilation fails with something like this:

In file included from /usr/include/libanjuta-3.0/libanjuta/anjuta-plugin-manager.h:25:0,
                 from anjuta-about.c:28:
/usr/include/libanjuta-3.0/libanjuta/anjuta-status.h:40:2: error: unknown type name 'GtkHBox'
/usr/include/libanjuta-3.0/libanjuta/anjuta-status.h:46:2: error: unknown type name 'GtkHBoxClass'

Expected results:
no error messages, anjuta should avoid using deprecated GTK types

Additional info:
I have found the issue when trying to compile gtkpod in RAWHIDE. Temporarily I have now removed -DGTK_DISABLE_DEPRECATED from the CFLAGS.

Comment 1 Johannes Schmid 2011-08-31 04:32:10 UTC
Note that this is fixed in anjuta master (and at least in 3.1.90) and that the change was only introduced with gtk+ 3.2. In general compiling a release with GTK_DISABLE_DEPRECATED is flawed - use it when building from git if you like but please disable it in releases as you never know what will be deprecated next and the release is set in stone for the time being.

Comment 2 Paul Richardson 2011-09-04 22:27:28 UTC
Johannes,

Seems reasonable.

Can certainly make a note to do that, unless there are major objections.

Cheers

phantomjinx

(gtkpod dev)

Comment 3 Gwyn Ciesla 2012-03-28 15:08:23 UTC
This seems to be fixed as of anjuta 3.2.0, with gtkpod 2.1.1., gtk3 3.4, in fc16.  Re-open if not.


Note You need to log in before you can comment on or make changes to this bug.