Bug 734610 - ldap users registering for RHQ with usernames of less than 6 characters fails
ldap users registering for RHQ with usernames of less than 6 characters fails
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.1
x86_64 Linux
high Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon3 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-30 17:56 EDT by Caerie Houchins
Modified: 2013-08-05 20:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Caerie Houchins 2011-08-30 17:56:27 EDT
Description of problem:
When an existing ldap user tries to register with RHQ for the first time, and their username is less than 6 characters long, a red ! appears to the left of their username with the mouse over text reading "Must be at least 6 characters".  The admin user can create local users that have usernames of less than 6 characters, its just not an ldap login.

Version-Release number of selected component (if applicable):
4.0.1

How reproducible:
Every time

Steps to Reproduce:
1. Create an ldap user whose username is less than 5 char
2. Login with this user to RHQ and attempt to register for the first time
  
Actual results:
cannot register

Expected results:
able to register

Additional info:
Comment 1 Ian Springer 2011-08-31 17:40:22 EDT
[master 5938708] fixes this. There is no longer any length restrictions on the username on the registration form.

It should be noted that the username field in the DB does have a maximum length constraint of 100 characters. I did not add a validator for that constraint, since it seems very unlikely to encounter LDAP usernames longer than 100 chars. However, one can easily be added if other people think it should be done.
Comment 2 Sunil Kondkar 2011-09-16 07:35:56 EDT
Verified on build#421 (Version: 4.1.0-SNAPSHOT Build Number: ad51846)

Registered and logged in to RHQ successfully as ldap user having user name less than 5 characters.

Marking as verified.
Comment 3 Mike Foley 2012-02-07 14:31:31 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 4 Mike Foley 2012-02-07 14:31:32 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.