Bug 734637 - kernel doesn't the right modules for synaptics to work on a Dell n4030 touchpad, making it be recognized as PS/2 Mouse
kernel doesn't the right modules for synaptics to work on a Dell n4030 touchp...
Status: CLOSED DUPLICATE of bug 590880
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-30 23:01 EDT by Alberto
Modified: 2011-09-14 07:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-14 07:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alberto 2011-08-30 23:01:36 EDT
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0

It seems that kernel isn't supporting synaptics modules for my touchpad, as it says in the xorg-x11-drv-synaptics description.

As i said, the touchpad is recognized as PS/2 Mouse, so moving the pointer and clicking works, but vertical/horizontal scrolling and other features of touchpads Don't.

Reproducible: Always

Steps to Reproduce:
1.Just boot my computer on Fedora.
Actual Results:  
my touchpad is happilly working as a PS/2 Mouse.

Expected Results:  
It shoud be recognized as a touchpad device, with scrolling an such, and with and touchpad configurations on the mouse section of system settings.

In Linux Mint 11 it works well and probably Ubuntu 11 as well. but in 10 no.
Comment 1 Thomas Spura 2011-08-31 07:23:10 EDT
Could you enable vertical/horizontal scrolling with e.g. "gpointing-device-settings" or "synclient"?

What's the output of "synclient -l"?
Comment 2 Alberto 2011-08-31 10:33:54 EDT

(In reply to comment #1)
> Could you enable vertical/horizontal scrolling with e.g.
> "gpointing-device-settings" or "synclient"?
> 
> What's the output of "synclient -l"?

output:
Couldn't find synaptics properties. No synaptics driver loaded?
Comment 3 Alberto 2011-08-31 10:37:14 EDT

(In reply to comment #1)
> Could you enable vertical/horizontal scrolling with e.g.
> "gpointing-device-settings" or "synclient"?
> 
> What's the output of "synclient -l"?

output:
Couldn't find synaptics properties. No synaptics driver loaded?
Comment 4 Dave Jones 2011-08-31 12:14:04 EDT
paste the output of xinput list please.
Comment 5 Alberto 2011-08-31 15:20:34 EDT
(In reply to comment #4)
> paste the output of xinput list please.

[alberto@alberto-dell ~]$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                      	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_0.3M           	id=10	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=13	[slave  keyboard (3)]
Comment 6 Chuck Ebbert 2011-09-12 13:21:31 EDT
It is not Synaptics, it's ALPS, and they have a new PS/2 protocol that they are keeping secret. Ask Dell why they are putting this device in their machines...
Comment 7 Chuck Ebbert 2011-09-14 07:20:22 EDT

*** This bug has been marked as a duplicate of bug 590880 ***

Note You need to log in before you can comment on or make changes to this bug.