Bug 734656 - Unable to run with error messages
Summary: Unable to run with error messages
Keywords:
Status: CLOSED DUPLICATE of bug 816230
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kdump
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 04:07 UTC by Noriko Mizumoto
Modified: 2014-01-13 00:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-14 09:51:50 UTC


Attachments (Terms of Use)
First error message window (353.94 KB, image/png)
2011-08-31 04:07 UTC, Noriko Mizumoto
no flags Details
Second error message window (375.91 KB, image/png)
2011-08-31 04:08 UTC, Noriko Mizumoto
no flags Details
'Path to directory' appears untranslated (376.19 KB, image/png)
2011-09-08 01:15 UTC, Noriko Mizumoto
no flags Details

Description Noriko Mizumoto 2011-08-31 04:07:05 UTC
Created attachment 520736 [details]
First error message window

Description of problem:
Closing two error messages exit the application, two screenshots for each message attached.

Version-Release number of selected component (if applicable):
http://dl.fedoraproject.org/pub/alt/stage/f16-translation/
Fedora-16-Nightly-20110828.10-x86_64-Live-desktop.iso

How reproducible:
Always

Steps to Reproduce:
1. yum install system-config-kdump
2. Issue the command system-config-kdump
3.
  
Actual results:
Two error messages are appeared and exited.

Expected results:
Successful run

Additional info:

Comment 1 Noriko Mizumoto 2011-08-31 04:08:21 UTC
Created attachment 520737 [details]
Second error message window

Comment 2 Roman Rakus 2011-09-01 07:17:38 UTC
Thanks for report. Can you please try to run it in selinux permissive mode? (setenforce 0).

Comment 3 Noriko Mizumoto 2011-09-08 01:15:38 UTC
Created attachment 522030 [details]
'Path to directory' appears untranslated

Comment 4 Noriko Mizumoto 2011-09-08 01:18:20 UTC
ok, thanks, now it runs successful with permissive mode.
It shows one English string which has been translated in PO file at transifex.
Please see attached screenshot.

Under 'Target Setting' tab, the third section of 'Network', the string 'Path to directory:' appears in English which has been translated at transifex.

Comment 5 Roman Rakus 2011-09-13 12:01:33 UTC
selinux bug was resolved, see bug #737643.
Error message fixed upstream: http://git.fedorahosted.org/git/?p=system-config-kdump.git;a=commit;h=e736248df26c7244e60f0a2017c082c307748f0f

I will pull in the patch...

Comment 6 Karel Klíč 2011-09-26 14:39:24 UTC
I am also unable to run system-config-kdump on Fedora 16 live cd. The two error messages are displayed as described by the reporter (the first one is displayed twice as two grubby calls fail).

Using SELinux permissive mode does not help here.

Nightly desktop compose 20110924.09
system-config-kdump-2.0.5-4.fc15.noarch

$ system-config-kdump 
/usr/share/system-config-kdump/system-config-kdump.py:341: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  self.xml = gtk.glade.XML ("/usr/share/system-config-kdump/system-config-kdump.glade", domain=DOMAIN)
/usr/share/system-config-kdump/system-config-kdump.py:341: GtkWarning: IA__gtk_radio_button_set_group: assertion `!g_slist_find (group, radio_button)' failed
  self.xml = gtk.glade.XML ("/usr/share/system-config-kdump/system-config-kdump.glade", domain=DOMAIN)
Unexpected error: <type 'exceptions.AttributeError'>

/var/log/messages
Sep 26 12:23:56 localhost dbus-daemon[1107]: subprocess call:
Sep 26 12:23:56 localhost dbus-daemon[1107]: ('/sbin/grubby', '--default-kernel')
Sep 26 12:23:56 localhost dbus-daemon[1107]: subprocess call:
Sep 26 12:23:56 localhost dbus-daemon[1107]: ('/sbin/grubby', '--info', dbus.String(u''))
Sep 26 12:23:56 localhost dbus-daemon[1107]: -> stderr = grubby: kernel not found
Sep 26 12:23:56 localhost dbus-daemon[1107]: subprocess call:
Sep 26 12:23:56 localhost dbus-daemon[1107]: ('/sbin/grubby', '--info', 'ALL')
Sep 26 12:23:56 localhost dbus-daemon[1107]: -> stderr = grubby: kernel not found

Comment 7 Roman Rakus 2011-10-31 16:38:04 UTC
(In reply to comment #4)
> ok, thanks, now it runs successful with permissive mode.
> It shows one English string which has been translated in PO file at transifex.
> Please see attached screenshot.
> 
> Under 'Target Setting' tab, the third section of 'Network', the string 'Path to
> directory:' appears in English which has been translated at transifex.

There is new pot file generated now. I don't know how to import it to transifex...

Comment 8 Roman Rakus 2011-10-31 16:39:23 UTC
(In reply to comment #6)
> I am also unable to run system-config-kdump on Fedora 16 live cd. The two error
> messages are displayed as described by the reporter (the first one is displayed
> twice as two grubby calls fail).
> 
> Using SELinux permissive mode does not help here.
> 
> Nightly desktop compose 20110924.09
> system-config-kdump-2.0.5-4.fc15.noarch
> 
> $ system-config-kdump 
> /usr/share/system-config-kdump/system-config-kdump.py:341: GtkWarning:
> GtkSpinButton: setting an adjustment with non-zero page size is deprecated
>   self.xml = gtk.glade.XML
> ("/usr/share/system-config-kdump/system-config-kdump.glade", domain=DOMAIN)
> /usr/share/system-config-kdump/system-config-kdump.py:341: GtkWarning:
> IA__gtk_radio_button_set_group: assertion `!g_slist_find (group, radio_button)'
> failed
>   self.xml = gtk.glade.XML
> ("/usr/share/system-config-kdump/system-config-kdump.glade", domain=DOMAIN)
> Unexpected error: <type 'exceptions.AttributeError'>
> 
> /var/log/messages
> Sep 26 12:23:56 localhost dbus-daemon[1107]: subprocess call:
> Sep 26 12:23:56 localhost dbus-daemon[1107]: ('/sbin/grubby',
> '--default-kernel')
> Sep 26 12:23:56 localhost dbus-daemon[1107]: subprocess call:
> Sep 26 12:23:56 localhost dbus-daemon[1107]: ('/sbin/grubby', '--info',
> dbus.String(u''))
> Sep 26 12:23:56 localhost dbus-daemon[1107]: -> stderr = grubby: kernel not
> found
> Sep 26 12:23:56 localhost dbus-daemon[1107]: subprocess call:
> Sep 26 12:23:56 localhost dbus-daemon[1107]: ('/sbin/grubby', '--info', 'ALL')
> Sep 26 12:23:56 localhost dbus-daemon[1107]: -> stderr = grubby: kernel not
> found

You are trying to set up kernel from live cd. It is not supported.

Comment 9 Roman Rakus 2012-06-14 09:51:50 UTC
There are new version available. Please test it and eventualy comment on bug #816230

*** This bug has been marked as a duplicate of bug 816230 ***


Note You need to log in before you can comment on or make changes to this bug.