Bug 73467 - First boot gets stuck recovering journal after dirty poweroff
First boot gets stuck recovering journal after dirty poweroff
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 20:38 EDT by Jim Prior
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 08:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Prior 2002-09-04 20:38:02 EDT
Description of Problem:
First boot after dirty poweroff gets stuck recovering journal

How Reproducible:
It did it several times, enough for me to write most of this bug report.  
Now I can not reproduce the bug.  

Steps to Reproduce:
1. Normal boot (after clean poweroff)
2. Turn off power (dirty!)
3. Turn on power and wait until it gets stuck
4. Turn off power (dirty!)
5. Turn on power.  

Actual Results:
Step 3 gets stuck checking filesystems: 
   /usr: recovering journal
hard drive light is stuck on.  
no head seek thrashing sounds

Step 5 boots successfully with following sample from /var/log/boot.log:
   Sep  4 20:11:09 localhost fsck: /usr: recovering journal
   Sep  4 20:11:09 localhost fsck: /usr: clean, 68423/263296 files, 431622/526128 b

Expected Results:
Successful boots after each dirty poweroff.  

Other Info: 
All the partitions are ext3 partitions except for swap.
Comment 1 Florian La Roche 2003-08-12 08:29:38 EDT
Cannot reproduce here, so closing down this bug-report.

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.