Bug 734697 - Impossible to set up an IPv6 multipath route
Summary: Impossible to set up an IPv6 multipath route
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: iproute
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 887594 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 08:01 UTC by Mathieu Bridon
Modified: 2014-10-15 09:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 09:41:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Debian BTS 556974 None None None Never

Description Mathieu Bridon 2011-08-31 08:01:59 UTC
Description of problem:
I'm encountering the same problem as reported in Debian:
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=556974

Doing multipath routing with IPv4 works fine, but it doesn't with IPv6:
    # ip -6 route add default nexthop via 2001:470:25:94::1 weight 1 nexthop via 2001:41e0:ff00:47::1 weight 1
    Error: an IP address is expected rather than "2001:470:25:94::1"

Note that the Debian bug doesn't specify it, but the problem happens even if you only specify one path:
    # ip -6 route add default nexthop via 2001:470:25:94::1 weight 1

This should be equivalent to the same command without the "nexthop":
    # ip -6 route add default via 2001:470:25:94::1 weight 1
    Error: an IP address is expected rather than "2001:470:25:94::1"

Again, this works perfectly fine with IPv4.

Applying the patch attached to the Debian bug fixes the parser error, but then it leads to another error:
    RTNETLINK answers: No such device

Version-Release number of selected component (if applicable):
    iproute-2.6.39-3.fc16.x86_64

How reproducible:
    100%


Steps to Reproduce:
    1. Make sure your network is IPv6 enabled
    2. Try adding a multipath IPv6 route (it doesn't have to have several "nexthop", one is enough to trigger the bug)

  
Actual results:
Parser error, then RTNETLINK error once the parser error has been patched.


Expected results:
A working IPv6 multipath route.


Additional info:
Sorry if this feels like a copy-paste of the Debian bug, but it's the exact same issue, only with Fedora 16 rather than Debian Squeeze :)

This bug also affects (at least) RHEL6. It seems you also maintain this package there, so I haven't opened a separate bug for it to avoid spamming you too much. Do you want me to also report it for RHEL6?

Comment 1 Mathieu Bridon 2011-11-01 09:36:38 UTC
Any news on this?

Comment 2 Petr Šabata 2011-11-01 16:31:53 UTC
(In reply to comment #1)
> Any news on this?

Ah, no.  I haven't looked at this much yet.  Thanks for the reminder :)

Comment 3 Petr Šabata 2011-11-29 15:51:03 UTC
The Debian patch seems correct in every way.  I wonder if there's another bug elsewhere...

Comment 4 Petr Šabata 2012-12-20 16:01:36 UTC
*** Bug 887594 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2012-12-20 17:03:36 UTC
iproute-3.6.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/iproute-3.6.0-5.fc18

Comment 6 Fedora Update System 2012-12-20 17:11:08 UTC
iproute-3.3.0-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/iproute-3.3.0-5.fc17

Comment 7 Fedora Update System 2012-12-20 17:12:19 UTC
iproute-2.6.39-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/iproute-2.6.39-8.fc16

Comment 8 Fedora Update System 2012-12-21 01:34:20 UTC
Package iproute-3.6.0-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing iproute-3.6.0-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20744/iproute-3.6.0-5.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-01-09 08:50:15 UTC
iproute-3.3.0-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-01-09 08:52:27 UTC
iproute-2.6.39-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-01-11 23:51:26 UTC
iproute-3.6.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 ddu 2014-10-14 06:18:54 UTC
It seems that this problem is still not fixed in RHEL6.

Do we have any plan to fix it in RHEL6?

Comment 13 Petr Šabata 2014-10-14 09:41:32 UTC
If this is an issue in el6, please open/clone this bug for the Red Hat Enterprise Linux 6 product.


Note You need to log in before you can comment on or make changes to this bug.