Bug 73475 - Bad: Incomplete screen rendering
Bad: Incomplete screen rendering
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks: 82776
  Show dependency treegraph
 
Reported: 2002-09-05 00:52 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 00:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested log files (7.11 KB, application/octet-stream)
2002-09-21 23:11 EDT, Need Real Name
no flags Details
log files and config files (150.00 KB, application/octet-stream)
2003-01-30 00:06 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-09-05 00:52:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
When using Mozilla (1.0.1-22), Galeon (1.2.5-6) or Netscape (7.0) the page is
not completely rendered. Passing the cursor over parts of the page causes links
and images to appear and disappear. I do not have this problem with the Konquer
browser, the only one I can use on my Linux system.  This problem appeared in
both the limbo and null releases.

Version-Release number of selected component (if applicable): 1.0.1-22


How reproducible:
Always

Steps to Reproduce:
1. Launch one of the browsers.
2. Go to www.redhat.com
3.
	

Actual Results:  Pages do not fully render. I can read almost nothing on the
page. I can some times stumble across a link that will work, I see that the pabe
is being loaded in the progress bar, but nothing much is painted onto the
screen. I tried to use the workaround identified in in bug report 72623, it did
not help.

Expected Results:  I should have been able to view the web page.

Additional info:

Using 7.3.94 (null) updated 9-3-02.

AMD 2100+ processor, ATI Radeon 8500 video. All hardware was correctly identified.
Comment 1 Christopher Blizzard 2002-09-11 11:46:30 EDT
Working great here.
Comment 2 Need Real Name 2002-09-12 23:14:54 EDT
I am not supprised that it works for you. It seems to be a problem with either
the video card or a combination of the video card and the CPU. None of the other
people that are running any 7.3 version of Red Hat have the problem except me.
For the record Mozilla and Red Hat 7.3.x has never worked on this computer. The
last version of Netscape to work was 4.7x.
Comment 3 Christopher Blizzard 2002-09-13 17:51:22 EDT
Over to mike to have a look.
Comment 4 Need Real Name 2002-09-14 00:12:12 EDT
I found a solution, here goes:
1. I installed a GeForce 4 MX 420 which caused the ATI Radeon 8500 to be
uninstalled.  The MX 420 worked just fine.
2: I reinstalled the ATI Radeon 8500 which caused the GeForce 4 MX 420 be
uninstalled.
3. After re-installation of the ATI Radeon 8500 the problem was no longer present.

Is there an easier way to have the system uninstall and reinstall the driver.
Comment 5 Mike A. Harris 2002-09-15 03:58:56 EDT
It sounds to me like perhaps anaconda and redhat-config-xfree86 might
perhaps be configuring things differently from each other.  Not sure
however.

In order to troubleshoot this, I will need a copy of your X server
config file and log file from when the problem is present, and
another copy of both from when the problem does not occur.

Are you positive in step 3 above that the problem does not recur?

Installing/uninstalling drivers wont have any effect.  Whatever the
problem is, it is a coincidence that this appears to solve the problem.

The problem either will occur all the time, or else something in
the configuration is being changed, and we just need to determine
what it is.

Can you attach the not-working and working X config and log files?

Also, please provide the output of:   lspci -vn

Thanks.
Comment 6 Need Real Name 2002-09-21 23:11:34 EDT
Created attachment 76808 [details]
Requested log files
Comment 7 Need Real Name 2002-09-21 23:18:05 EDT
I have attached the log files and the lspci -vn listing. I do not have any files
that I am sure are from when the system problem existed. The only way I know to
cause the problem to reappear is to reload 7.3.94 from scratch. Do you know of a
simpler was to recreate the problem?

It sounds to me like perhaps anaconda and kudzu might be configuring things
differently from each other.
Comment 8 Mike A. Harris 2003-01-24 16:26:42 EST
Please attach all files that are text content as individual text file
attachements in all bug reports for ease and speed of viewing while
troubleshooting.
Comment 9 Need Real Name 2003-01-30 00:06:51 EST
Created attachment 89712 [details]
log files and config files
Comment 10 Need Real Name 2003-01-30 00:07:43 EST
First the problem:

After installing Red Hat 8.0

Mozilla 1.0.1-24 would not correctly update the screen. Pieces of the screen would
paint while others did not. Moving the mouse caused different parts of the screen
to repaint.

I found a solution, here goes:
1. I removed the Radeon 8500 video adapter from the computer and installed a Nvidia
   Rivia TNT2.
2. Restarted the computer and the new video adpater was detected.
3. When XWindows started the mouse did not work correctly so I ran
redhat-config-mouse,
   still did not work correctly, so I ran redhat-config-xfree86 and restarted the
   computer.
4. After the restart everything worked just fine.
5. I then removed the Nvidia Rivia TNT2 and reinstalled the Radeon 8500 video
adapter.
6. Restarted the computer and the new video adpater was detected.
7. When XWindows started the mouse did not work correctly so I ran
redhat-config-mouse,
   still did not work correctly, so I ran redhat-config-xfree86 and restarted the
   computer.
8. After the restart everything worked just fine.

The experiment
1. I replaced the working XF86Config with the bad one and restarted the computer the
   problem was back.
2. I replaced the bad XF86Config with the good one and restarted the computer and
   the problem was gone.

Analysis

The real problem was that file generated by anaconda was not correct and the file
generated by redhat-config-xfree86 was good.  The easy fix to the problem would have
been to have run redhat-config-xfree86 in the first place.

The files are attached.
Comment 11 Mike A. Harris 2004-08-30 00:17:01 EDT
This problem sounds like it was a hardware problem with your specific
setup.  I'm unable to reproduce any rendering corruption using
mozilla on radeon hardware.

Setting status to "WORKSFORME".  Please upgrade to Fedora Core 2
and if the problem persists, feel free to open a new bug report
on X.Org bugzilla at: http://bugs.freedesktop.org in the "xorg"
component.  If you do encounter the issue again, you can paste
your upstream bug report URL from X.Org bugzilla here, and we will
track the issue in upstream bugzilla.

Note You need to log in before you can comment on or make changes to this bug.