Bug 734758 - munin reporting failed test trough cron and email
Summary: munin reporting failed test trough cron and email
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: munin
Version: el6
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 11:18 UTC by Rosco
Modified: 2011-09-29 03:27 UTC (History)
2 users (show)

Fixed In Version: munin-1.4.6-4.el6.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-29 03:27:47 UTC


Attachments (Terms of Use)

Description Rosco 2011-08-31 11:18:56 UTC
Description of problem:

After the recent update, Munin sends email messages to the admin every 5 minutes with the title:

"Cron <munin@hostname> test -x /usr/bin/munin-cron && /usr/bin/munin-cron"

and the body explaining that munin-update didn't find the /etc/munin/munin-conf.d folder. "no such file or directory" 

It was not the case before the last week update.

Version-Release number of selected component (if applicable):
munin-1.4.6-3.el6.noarch

How reproducible:
update munin to the latest version from EPEL and start it. Wait for the emails to come.

Steps to Reproduce:
1. yum install munin
2. /etc/init.d/munin-node start
3. wait for munin to start scanning
  
Actual results:
a flood of email messages 1 every 5 minutes for every host running munin.

Expected results:
no email messages

Additional info:
The folder scanned doesn't exist on a default installation. I think the folder scanned by the munin-update script should be called /etc/munin/conf.d instead of /etc/munin/munin-conf.d
I've create an empty folder /etc/munin/munin-conf.d and the spam stopped.

Comment 1 Kevin Fenzi 2011-09-10 17:49:55 UTC
Sorry for the delay. 

Can you try: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=3341702

and see if it fixes the issue for you?

Comment 2 Rosco 2011-09-12 09:59:16 UTC
Thanks for the fix, it seems to be working now. On a machine that had no munin installed and on a machine where I updated from 1.4.6-3.

Comment 3 Fedora Update System 2011-09-12 20:35:17 UTC
munin-1.4.6-4.el6.2 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-1.4.6-4.el6.2

Comment 4 Fedora Update System 2011-09-13 02:28:39 UTC
Package munin-1.4.6-4.el6.2:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing munin-1.4.6-4.el6.2'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/munin-1.4.6-4.el6.2
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-09-29 03:27:42 UTC
munin-1.4.6-4.el6.2 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.