Bug 73485 - I18N-Support is very weak
I18N-Support is very weak
Status: CLOSED DUPLICATE of bug 78221
Product: Red Hat Linux
Classification: Retired
Component: rdesktop (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
http://bibl4.oru.se/projects/rdesktop/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-05 06:12 EDT by Mirko Zeibig
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 06:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mirko Zeibig 2002-09-05 06:12:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
When invoking the null-provided rdesktop, non US-keyboard are almost unusable. 
1. You have to figure out the correct mapping between country and a
   numeric country-code
2. The german keyboard will not let you enter things mapped with AltGR (e.g.
@\{}[]).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Invoke rdesktop with the option for an international keyboard.
2. Connect to a Terminal-Host
3. Try to use {@\.


Additional info:

The unified patches at http://bibl4.oru.se/projects/rdesktop/ provide a way out.
I use rdesktop-unified-patch19-9-0 rather happily and had no problems so far.
The Keyboard is working as it should and instead of remembering a number for the
keyboard-translation one may use two-letter countrycodes like 'de' or 'fr'. The
command will show you all available translations if invoked with the help-option.
Comment 1 Alexander Larsson 2002-09-05 06:25:51 EDT
I'll take a look at integrating it in the future.
Comment 2 Alexander Larsson 2002-11-20 06:02:15 EST
Duping to bug with better title.


*** This bug has been marked as a duplicate of 78221 ***

Note You need to log in before you can comment on or make changes to this bug.